1

I don't understand why upsell doesn't show 1 product in the frontend. All upsell products are showing up except for 1. I've reindexed all data, but still no changes. All upsell products are in stock, they all have quantity and they are all enabled, but still 1 product doesn't show up in the frontend. I've tried to check only 1 product, which is the product that is missing but didn't show up, any help, please. Thanks. By the way, it is not modified in the catalog.XML so the product limit is not the issue.

here is the backend http://ecommerceoutsourcing.co/projects/UMD/magento/skin/frontend/default/theme542/images/upsell_products_backend.png

and here is the frontend http://ecommerceoutsourcing.co/projects/UMD/magento/skin/frontend/default/theme542/images/upsell_products_frontend.png

  • if you load the product in the frontend directly with the Mage_Catalog_Model_Product class and call isSaleable, what does it return? – Sander Mangel Mar 17 '15 at 0:08
  • I'm sorry, but I don't get it, how do you do that? Do I have to modify the upsell.phtml? I set all upsells in the backend. Thanks – Ken Avila Mar 17 '15 at 3:11
  • @Sander means try opening the product directly. Can the product be added to your cart? Maybe the upsell product itself is out of stock or disabled. – Jeroen Mar 18 '15 at 16:53
  • They are all in stock. I made sure that they are all in stock, take a look of the PRODUCT B info ecommerceoutsourcing.co/projects/UMD/magento/skin/frontend/… – Ken Avila Mar 19 '15 at 2:19
  • and all products are enabled – Ken Avila Mar 19 '15 at 2:26
0

Please check on Visible and make sure it go with "Catalog,Search" :) That worked for me, hope it help some one.
enter image description here Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.