0

In Magento I configured global prices - 1 price for all websites/stores/languages. Unfortunately, Magmi imported prices in the website tables (in case there is anything like a website table). So now I've got global prices if I manually enter a product and I if use Magmi to import a product into two different languages, I've got website scope prices.

Is it somehow possible to delete the website prices and tell Magento (or does it do it by itself) to use the global prices?

Thanks, Chris

1

First, I would do what Sanders said and change your price scope to "Global". Then, if for whatever reason you have website prices that persists, I would run the following query, which will return all of the non global prices saved on your database.

SELECT d.entity_id AS product_id,d.value AS price
FROM catalog_product_entity_decimal AS d
    INNER JOIN `eav_attribute` AS a
        ON d.`attribute_id` = a.`attribute_id`
WHERE a.`attribute_code` = 'price'
    AND d.store_id != 0

First examine these records, if any. If you're seeing website prices, this query should return some results. If you remove these records, all prices will fall back to the global price (store_id = 0). Proceed with caution and always test it on a dev environment first!

  • Don't do this on a production environment and always make a backup first. ;) – Sander Mangel Mar 17 '15 at 10:31
  • Edited slightly :) – musicliftsme Mar 17 '15 at 13:10
  • A bit scary but after backups and testing around it seems as if it's working fine - thank you @musicliftsme for this solution. I used: code DELETE d.* FROM catalog_product_entity_decimal AS d INNER JOIN eav_attribute AS a ON d.attribute_id = a.attribute_id WHERE a.attribute_code = 'price' AND d.store_id !=0 – Chris Mar 19 '15 at 2:32
2

If you set the Catalog Price Scope to Global under System > Configuration > Catalog > Price it should ignore any prices on the website level.

enter image description here

  • Yes, but it doesn't do it. In the category view it still shows the global prices and after clicking on a product I get the website prices. – Chris Mar 16 '15 at 9:24
  • Hm, that's weird. If you change the global price scope, it should only use the global price. Have you re-indexed? – musicliftsme Mar 16 '15 at 14:11
  • I never ever had the price scope not being global. Should I try to change it to website, reindex, change it back to global, reindex? Doesn't sound reasonable to me!? – Chris Mar 17 '15 at 8:38
  • Maybe it is a wrong setting within Magemi, because this tool writes to the database directly. If so, it is out-of-scope. @Chris please check your import settings in Magemi – Jeroen Mar 17 '15 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.