1

I've tried to install Magento 2 0.42.0-beta11 on Windows 7 machine with Apache. After install homepage doesn't have any styles or images - http://joxi.ru/Vm6ko9ni7oWG2Z.

If i try to open any css or js from page i get Warning!symlink(): Cannot create symlink, error code(1314) - http://joxi.ru/823gozRi5vpJ2O

Previously i had Magento 2 0.42.0-beta7 and there was everything ok. Looks like they changed aproach of css/js generation.

Same issue exist when i open admin panel.

Please assist.

1

1 Answer 1

4

Please open up an issue on the Magento 2 Github so the core team can investigate and fix this issue.

In the meantime you can try the following workaround.

Open up app/etc/di.xml file and find the following xml snippet:

<virtualType name="developerMaterialization" type="Magento\Framework\App\View\Asset\MaterializationStrategy\Factory">
    <arguments>
        <argument name="strategiesList" xsi:type="array">
            <item name="view_preprocessed" xsi:type="object">Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink</item>
            <item name="default" xsi:type="object">Magento\Framework\App\View\Asset\MaterializationStrategy\Copy</item>
        </argument>
    </arguments>
</virtualType>

Replace the above with the following by modifying the line that starts with <item name="view_preprocessed" to use the Copy strategy.

<virtualType name="developerMaterialization" type="Magento\Framework\App\View\Asset\MaterializationStrategy\Factory">
    <arguments>
        <argument name="strategiesList" xsi:type="array">
            <item name="view_preprocessed" xsi:type="object">Magento\Framework\App\View\Asset\MaterializationStrategy\Copy</item>
            <item name="default" xsi:type="object">Magento\Framework\App\View\Asset\MaterializationStrategy\Copy</item>
        </argument>
    </arguments>
</virtualType>

Not the answer you're looking for? Browse other questions tagged or ask your own question.