2

I have a fresh install of Magento 1.9.1.0

Enabled Cofigurable Swatches: enter image description here

Created attribute set with color attribute options: enter image description here

Added configurable product and associated products with this picture set and lables: enter image description here

So everything is by the book but the images are not switching.

Check it here: http://test.musicshop-no1.hr/index.php/gitare/korg-guitar-tuner.html

What am I doing wrong?

1
  • I can't tell from the image if the 'exclude' checkbox is checked, that may cause issues as I don't believe it's supposed to be. Alternatively clearing cache fixes everything.;) Mar 13, 2015 at 16:18

2 Answers 2

1

I guess your template is not compatible with configurable swatches, try using this guide to implement configurable swatches into your template: Guide Link

P.S. Had same problem few hours ago, done and working ;-) Have you tried flushing image cache?

5
  • It's the default rwd theme. Mar 13, 2015 at 16:13
  • It's the default rwd theme as Cags said, and it supports it by default. Flused image cache and still no progress. Mar 17, 2015 at 12:00
  • Try labels in lowercase.
    – JusLinTek
    Mar 18, 2015 at 19:04
  • Tried labels in lowercase, no success :/ Apr 13, 2015 at 12:03
  • Can you take a screenshot of your console log? And as well network tab log? Might be js errors related to missing files.
    – JusLinTek
    Oct 15, 2017 at 0:38
1

I ran into a similar issue using a custom implementation of RWD, so it might help to look this over:

Configurable product image not switching with swatch change

The main issue was tracking down the correct files that needed to be loaded on the front end for the JS to work. Taking a look there would be where i would start.

After that i would check the file permission, as they can seemingly get out of wack depending on changes that might have been made to the server, file system or install of some extensions ect......Take a look to see if there are any 404 errors in the developer console of your browser, as the files you are trying to switch to might not be found.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .