3

I have been trying to schedule a cron job at 1830 hours daily but it never is scheduled

<cron_expr>30 18 * * *</cron_expr>   //This never works
<cron_expr>0 18 * * *</cron_expr> //This also does not work

However when I schedule a cron using the minutes expression, it is always scheduled

<cron_expr>*/10 * * * *</cron_expr> //This surprisingly works!

I understand that Magento schedules crons using the UTC timezone, and the expressions that I have tried are to do with times in UTC.

Below are my cron settings from Admin

Generate Schedules Every : 15
Schedule Ahead for : 60
Missed if Not Run Within : 60
History Cleanup Every : 120
Success History Lifetime : 120
Failure History Lifetime : 3000

Can someone help me with what am I missing out?

  • Have you tried installing AOE Scheduler ? – brentwpeterson Mar 15 '15 at 12:03
  • Your question is unclear: You need to add some more information like if it is not scheduled at all or if there's maybe an error showing up and related to this. And try installing Aoe_Scheduler (as suggested by @brentwpeterson in the comment above). – Anna Völkl Mar 18 '15 at 13:11

Browse other questions tagged or ask your own question.