4

I'm testing Magento EE 1.14.1 using the RWD theme (rwd/default) and have come across the following problem.

  • I've created a very simple banner which is just plain text. It is not associated with a promotion or a segment.
  • To preview I've inserted the banner into a standard CMS page using
    the insert widget tool and then the rotating banner method (set to show all banners at once). I've assigned the banner to this.
  • Caching is turned off so no need to flush.
  • When I go to view the page on the frontend the banner is not displayed.
  • If I change the theme back to the original enterprise/default and view the page the banner displays.

I've also tried viewing the banner using the widget with a layout position (multiple layout positions) but to no avail.

Is anyone aware of anything I am doing wrong? Has anyone else come across this problem or able to replicate it. I've tried on two instances of EE and the problem happens on both.

Is this a bug or an error on my part? and if anyone has a solution I would be very grateful.

1

The problem is when you use the rwd/default template, that you have to make sure that it's parent is enterprise.

You can add/change a file etc/theme.xml to rwd/default with

<?xml version="1.0"?>
<theme>
    <parent>enterprise/default</parent>
</theme>

That way, Magento's lookup is changed from

  • rwd/theme
  • rwd/default
  • base/default

to

  • rwd/theme
  • rwd/default
  • enterprise/default
  • base/default

There's also a rwd/enterprise so be sure to set it correctly in the Magento backend.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.