2

I cannot import a customer-csv if the ‘website’ field is missing, or empty or containing ‘ETK-shop’. This field has to contain the value ‘ADMIN’ Then the import goes well, without errors.

However, if the field ‘website’ contains 'ADMIN', the customer cannot log in. I need to change the value of ‘website’ field to ETK-shop for the customer to be able to log in. But this cannot be done via ‘Manage Customers’ (?). So I need to alter the field website_id in the table ‘mage customer entity’:

UPDATE `etkm01_mage1`.`mage_customer_entity` SET `website_id` = '1' WHERE `mage_customer_entity`.`entity_id` =8201;

This does not seem the right way to get it to work. So what am I doing wrong? How can I import customers with the right website/-id?

2

Be sure to use the website-code as fount under System / Stores (screenshot)

Website code

Or create a customer manually in the webshop. Export customers and look what the value of website is. Use this again your the import.

I think it differs from ETK-shop.

The customers you are importing become Admin only and therefore you cannot login from the website.

Added after extra info about the error

Error: Skipping import row, website "%s" field does not exist.

I've took a look at the code, I would almost there is a error in the content entry. Website codes are matches case sensitive, to be sure nothing goes wrong, try entering them both in website and in csv lowercase.

Maybe you could edit System / Stores -> Website and set the code again(lowercase) and the in the import(lowercase). Then try again.

  • I had tried this before many times, but just now tried again. If I export the new (with website ETK-shop) customer I see ETK-shop in the website field in the exported file. If I import that customer again, I get 'Skipping import row, website "ETK-shop" field does not exist.' If I change the value of the field website to admin again, import goes ok. – lidacha Mar 14 '15 at 7:58
  • I've took a look based on your error, will add updated answer – Jeroen Mar 16 '15 at 9:00
  • Thank you so much! I had already tried importing with lower case, although in the export it was uppercase, but no difference. So I was about to follow your suggestion to change the website name to lowercase, when I saw that, although the website name was ETK-shop, the Code was “base”! So I tried importing with website=“base” and bingo! Still find it strange that the export has “ETK-shop”, the Website Name, in the website field and you have to import with “base”, the Code. – lidacha Mar 16 '15 at 13:59
  • Hooray! Great that it is resolved! I'll add the "be sure to use the website code" so when others find the question it will be easier to guess. – Jeroen Mar 16 '15 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.