1

I'm using Magento 1.9.1. I recently received a call from a potential customer that claimed she tried to purchase from the website the night before but was unable to. Before this I had two sales as well as numerous test sales with no issues.

I called her back and she said that there was some sort of timeout that prevented her from making the sale.

Unfortunately, I didn't have logging turned on in Magento and have turned off regular access logs in nginx, only had error log showing which showed nothing. Google Analytics was turned on but no Pingdom uptime checker turned on at the time.

I'm trying to figure out exactly what happened and thought someone may know more of have some insights. I'm running Redis for the caching. My thought at first was that either VPS webhost was having some slowness at the time. Another thought I had was that the daily backup or log cleaning setting in Magento was running at the time. However, upon further inspection, I don't believe the log cleaning feature in Magento did anything since logging wasn't enabled and I didn't see any recent backups done either.

Maybe there is a timeout value in php, redis, nginx or something that would have caused a timeout? If anyone has any suggestions or opinions on what caused the problem or ways to find out, please feel free to respond.

4
  • Check the visitor log table.
    – user4351
    Commented Mar 12, 2015 at 8:23
  • Urn on logging so the next time you know what is happening. If it happens again, maybe it was a glitch
    – Jeroen
    Commented Mar 13, 2015 at 11:29
  • Thanks. There was nothing in the logging table for visitors. Logging was previously disabled as mentioned in my post.
    – MeanJ
    Commented Mar 14, 2015 at 0:06
  • Are you sure your customer is giving you correct info? Sometime they want discount and blames the system. Commented Mar 3, 2016 at 4:26

1 Answer 1

1

check the region of the customer's. I recently had an issue with gateway timeout outside USA, yet I was able to access the same pages quite alright in USA, where my server is located. I later found out that DHL deprecated was the reason behind it and ever since it was disabled, everything worked out well. Also check if reports is creating a log for what is happening. I got some reports regarding mine, but they did not pinpoint the actual cause until I started disabling components one by one. May be your reports will be more useful for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.