3

I have seen many similar posts describing the problem I am experiencing, but I have been so far entirely unsuccessful in trying to resolve it. I recently upgraded to Magento CE 1.9.1.0, and now I get a blank page when navigating to System > Configuration in the back-end. The rendered page contains only empty html and body tags.

The error:

The only error that I get (in the logs or on screen with display_errors enabled in the index.php) when opening the configuration page (or any other admin page) is the following:

Fatal error: Call to undefined method Zend_Locale::getAlias() in app/code/core/Mage/Core/Model/Locale.php on line 243

Referer: http://example.com/index.php/magento/index/index/key/.../

The relevant line from Locale.php is:

$allowedAliases[Zend_Locale::getAlias($code)] = $code;

I have attempted:

  • Refreshing and/or disabling all caches.
  • Disabling all non-Mage modules in app/etc/local.xml (disable_local_modules), app/etc/modules (<active>false</active>), app/code/local and app/code/community (removing all files).
  • Tried both PHP 5.4.16 and 5.5.21
  • Comparing all files in app/ and lib/ with those from a fresh install. None were missing, but I attempted refreshing them anyway.
  • Refreshing the user permissions by opening and saving the Administrator role in System > Permissions > Roles.
  • Checked and re-checked file permissions, having tried both the Magento recommended perms and fully permissive (777).

System specs:

  • CentOS 7
  • Magento CE 1.9.1.0
  • PHP 5.4.16 or 5.5.21
  • Sounds like one of the core setup scripts fails to complete. Install n98-magerun and run its sys:setup:incremental, while configuration cache is clean but active. – Melvyn Mar 12 '15 at 8:40
  • What an excellent toolkit. I activated and cleaned all caches. sys:check gives a clean bill of health. sys:setup:incremental produced the following output: Found 68 configured setup resource(s) / Found 0 setup resource(s) which need an update. After that I restarted apache, but the problem persists. – Craig Stone Mar 12 '15 at 10:17
  • Is your head section filled in the source? I find it rather odd that body is empty, but had a closing body and html tag. Is that not the browser reformatting what is really zero sized response? And if it is, what is the response status? 50x? And what value for the x? ;-) – Melvyn Mar 12 '15 at 10:26
  • The HTML head tag is present, but empty. Digging some more through the HTTP headers has revealed a 500 Internal Server Error from which I infer that the browser is receiving no content at all from Magento. The only error that is evident in the logs is the persistent Locale.php one. – Craig Stone Mar 12 '15 at 10:34
  • Ok that makes more sense. You'll only catch this if you manage to get error logging enabled in php. Also, any Ioncube involved here? – Melvyn Mar 12 '15 at 10:40
2

I got the same message after upgrading from 1.9.0 -> 1.9.1. Problem was fixed by reinstalling Lib_ZF_Locale 1.12.7.0 via Magento Connect Manager.

1

I had the same problem. And this answer worked for me.

I got the same message after upgrading from 1.9.0 -> 1.9.1. Problem was fixed by reinstalling Lib_ZF_Locale 1.12.7.0 via Magento Connect Manager.

But the reason why it happend was because Magento turned off SSLv3 on Magento Connect. The solution for that is found here Magento 1.9.2 Unknown cipher in list: TLSv1 In file downloader/lib/Mage/HTTP/Client/Curl.php I changed the code

$this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1'); 
to
if(isset($var)){
   $this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1');
}

Only after this change could the last updates be done. In my clients case there where 4 core files not updated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.