1

We have a Magento site that was copied over from an existing Magento site we have, so all products, setting, etc are simply copied to a new domain.

This was done months ago but I am just now trying to use the site. Frontend of site seems to be working great.

Admin panel, in the edit categories page, it keeps "Loading"

I look at the Browser COnsole on this page instantly see this problem....

Mixed Content: The page at  
'https://www.domain.com/index.php/admin/catalog_category/index/key/7ac5ce7838cd82114132424faf2b5656/'  
was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint  
'http://www.domain.com/index.php/admin/catalog_category/edit/key/40eeadefd754406a47f2993be70c4472/?isAjax=true'.  
This request has been blocked; the content must be served over HTTPS.

So it appears this page is making an AJAX call to http://www.domain.com/index.php/admin/catalog_category/edit/key/40eeadefd754406a47f2993be70c4472/?isAjax=true notice the http instead of https

I think fixing this will fix our issues.

In admin config I saw this setting: Use Secure URLs in Admin was set to No so I changed it to yes but no luck on the error going away just yet.

Any ideas how to resolve this please?

UPDATE

It seems my Admin setting for ``Use Secure URLs in Adminis not saving! So changing it;s value toyesis not saving and end up staying asno` so it seems we have more issues. The solution to the admin setting saving could fix the other issue.

Any ideas here?

5

I got it fixed now, i'll explain the process below...

My admin panel was loading through HTTPS URL's due to our server configuration. However in the Magento Admin panel this option

Config > General > Web Use Secure URLs in Admin was set to NO

enter image description here


I knew changing this to Yes would probably fix all our admin panel issues. However changing it to yes and hitting Save Config would submit and show a message indicating it had save the config. However the value for that option above still showed up as No!

So in Chrome Developer Tools, I viewed the source of the webpage and found the <form> that was on the options page.

enter image description here


After changing the Form URL to https in the DOM, I then changed the option to a yes value again and hit Save Config. This time since it made my POST to the correct https URL, it actually made the save and updated the value!

With that updated, all my admin problems are resolved!

  • awesome. You save my life. Thanks so much – NhatVM Dec 8 '18 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.