1

I am using Magento Enterprise 1.9.1.0.

After creating two client account to run tests, I placed two order, one for each client. An order confirmation for the first order is sent to both client 61 times per hour since then. I tried removing all mention of the sending sales@ email address from the configuration panel and disabling email sending from config. Both the server and the template support indicate that it stems from a bug in Magento.

How can I : 1. Stop the flow of email 2. Ensure proper functioning of automated order confirmation sending

1

This issue could be related to the new Magento Email Queue system, that leaves orphan records on the Recipients table.

If this is your issue, I've sent a fix on this post: https://magento.stackexchange.com/a/87299/23057

0

In the backend there's an option to turn off all mail sending:

System > Configuration > System > Mail Sending settings

Set "Disable Email Communications" to "Yes". This and:

System > Configuration > Design > HTML Head > "Display Demo Store Notice"

is what I try to do with every new test / development install. Now, why your mail is not being marked as sent, is difficult to say. Judging from the code, a field "processed_at" should be NOT NULL for a message to be considered as sent. This is done by Mage_Core_Mode_Email_Queue::send().

If an exception is thrown, then processed_at never gets set. I can only assume that your mailer returns a non-transient error code.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.