0

While testing my checkout process, I buy an item and in the Sales, Orders admin screen, in the payment information box, I get 'CreditCard Payment has not been processed yet.' Instead of the credit card details, name of account holder etc.

In the comments history it says 'The payment was successfully processed.'

After checking the phtml template in the path hints, I think my problem is that

$this->getInfo()->getData('additional_information');

from

class Mage_Payment_Model_Info extends Mage_Core_Model_Abstract

is empty. Why could this be happening, or is there a way for me to retrieve the additional information as an array?

Any help would be much appreciated.

0

It depends on the payment method, but there's quite a few that delay the callback to Magento for credit card or other types of payments that require additional checks.

So on your success page this information is not yet available as the payment provider hasn't called back to Magento yet.

  • Hi Melvyn, sorry for the delay and thanks for your answer. The payment provider confirmed it had processed the payment and the summary screen also had a message confirming this. I'll have a deeper dig on this when I have the time. – Michael Mar 18 '15 at 12:22
0

The system.log was showing an error after purchase

SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry '100000801' for key 'UNQ_SALES_FLAT_INVOICE_INCREMENT_ID', query was: INSERT INTO `sales_flat_invoice`....

Thanks to hints from here, I was able to run

select entity_type_id, entity_type_code from eav_entity_type;

which gave me the entity_type_id for invoice.

Running

SELECT * FROM eav_entity_store;

Showed me the increment_last_id for invoice that was causing me bother. So I just updated that line (after backing up the database) of the table to a new unique value

UPDATE eav_entity_store SET increment_prefix = 3, increment_last_id = "300000001" WHERE store_id = 3 AND entity_type_id = 6;

Placing an order now gives me the additional information in the sales order page. I think reason for the problem was that the invoice number extension I had was no longer compatible with my current version of Magento.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.