2

When I go to Sales -> Terms and Conditions -> the page to edit my conditions, there is no WYSIWYG to edit the content. I have a responsive website. If I put unformatted text on the terms and conditions, it overflows the content box on the front office.

unformatted text view

If I put HTML tags on the back office, it still overflows on the front office and when I inspect the element, I can see that Magento adds a tag with "plain plain" class.

code tag

I tried to switch the "show content as" from text to HTML but it does nothing.

How can I customize the terms and conditions ? How can I do so it doesn't overflow ? Why is this tag appearing ?

I have Magento ver. 1.9.1.0

3
  • You should just be able to style the code tag so that it doesn't overflow it's parent. Commented Mar 6, 2015 at 8:16
  • @Cags I can't do that. If a the code tag with the same class is used on another page that I don't want to change, it will change its style too.
    – Anais
    Commented Mar 6, 2015 at 8:48
  • So use a more specific css selector. However I can't imagine on any page you want a code tag that isn't contained within the layout of the page. Commented Mar 6, 2015 at 8:57

1 Answer 1

0

Seems like a company developped a module to enable WYSIWYG on the terms and conditions page.

If you're a developer I reckon that shouldn't be hard to develop but as the module is only $17 I guess that's worth a try.

Here's the link: http://codecanyon.net/item/terms-conditions-using-wysiwyg/7182836

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.