1

While preforming a backup, I got hung up and had to refresh page (after an hour) "Put the site in maintenance mode" was checked. Now my admin log in is redirecting to the site itself. I deleted maintenance.flag through ftp but I'm still unable to log into my admin panel. I added some "allow IP code" to my index.php file but again, no go. Any other suggestions?

3 Answers 3

1

Look in your Magento root folder for a file called maintenance.flag and rename or delete it. You should then be out of maintenace mode

3
  • I did that first - it must not have worked because I still can't log into admin panel. Also, I added some "allow IP" code to index.php without success.
    – JVerrinder
    Mar 3, 2015 at 22:51
  • have you tried taking a fresh index.php file and lobbing in that? (rename/backup you current index.php file) Mar 4, 2015 at 10:37
  • Yes, I have replaced the index.php with a fresh file - still locked out.
    – JVerrinder
    Mar 4, 2015 at 23:42
1

If you get redirected to the site, but not to the installer and you don't get a 503 maintenance mode page, then your admin URL has changed. Look in your local.xml.

If you get the 503 template and IP exceptions don't help, check for an alternate maintenance mode extension (BalkeTechnologies StoreMaintenance is one I frequently see). Another possibility is that there's a reverse proxy in the chain and it's hard-caching error messages. In that case request the admin with a query string, triggering a refresh (normally).

Finally, Redis_Session module also throws a 503 if it can't connect to Redis.

-2

Deleted the maintenance.flag file and the site is back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.