2

I got the following message from paypal saying:

Please check your server that handles PayPal Instant Payment Notification (IPN) messages. Messages sent to the following URL(s) are not being received: https://www.MYSITE.com/paypal/ipn/ If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information. Once you or your service provider fix this problem, you or your service provider can resend the failed messages from the IPN History page. If this problem continues, PayPal may disable the IPN feature for your account. Thank you for your prompt attention to this issue. Thanks, PayPal

My version of Magento is 1.6.0.0 and I am using Paypal Express checkout. Furthermore, this url is possibly working (as it doesnot take you to 404, rather gives me a blank page).

Secondly, I looked into the code (app\code\core\mage\Paypal\Model\Express.php) and I see the following line: ->setNotifyUrl(Mage::getUrl('paypal/ipn/'))

Hence, it looks like a valid url. The only thing left is to add \index.php\ to it.

So can you please tell me:

  1. Is this a valid url for my version of magento and paypal?
  2. How to be sure if its working? I did sandbox testing and all was working well. The orders were marked as Processing with paypal info received (including Transaction ID) from paypal... I hope it didnt come from PDT (Payment Data Transfer) instead of IPN.

Here is more: The original email says:

Once you or your service provider fix this problem, you or your service provider can resend the failed messages from the IPN History page

However, I just checked on paypal.com and there are no failed IPN messages... all messages were sent successfully.

1

This thread reply might help you: http://www.magentocommerce.com/boards/main.php/viewthread/285840/#t411910

I am posting this follow-up to say that I disabled IPN notifications in my PayPal account and everything is still working fine.

The IPN url setting in PayPal doesn’t have an effect on Magento because Magento is sending the IPN url with each transaction request anyways. Each time Magento sends a transaction to PayPal, this IPN url will override the default IPN settings in your PayPal account so that, in other words, the settings in the PayPal account have no effect on Magento.

I checked my IPN history in PayPal and the IPN notifications are being successfully sent back to Magento even though I disabled the global settings in PayPal. On the Magento side, everything is working smoothly too.

0

If you have eBay on the same PayPal account, this could be that Magento is reponding IPNs sent from PayPal that relate to eBay transactions.

Magento will not recognise the order numbers in the IPN and return a 503 error

The only fix I have is to edit \app\code\core\Mage\Paypal\Model\Ipn.php to return a 200

so around line 177 change the "503 Service Unavailable" to "200 OK"

you might want to change the log message at line 174 so that you know this is executing

  • Heard the first time of it. Normally Paypal is triggerd via <form> including a return url – Fabian Blechschmidt Jul 29 '14 at 12:29
  • In my case, when I originally set up a (several years ago) UK PayPal account with Magento, I had to set the Magento listener URL in the Global IPN settings of PayPal. Without this, not all neccesary IPNs were sent to Magento such as refunds made directly through PayPal (I think this was an issue with PayPal at the time). For some reason, eBay transactions do not overide the Global setting so the eBay transactions also get sent to the Magento listener. At the time I took this up with PayPal but didn't get very far. setting in PayPal again. Maybe it is time to try turning off the global again ! – Spiyda Jul 31 '14 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.