A site I took over is acting very funny after we moved it to another database and directory. I am going to give two links, the same page from two different sites. What happened is, we had a development site in one directory and a production site in the root dir. We just copied over the dev site to the root and changed the local.xml to point to the prod. database. now the product pages are acting weird. One difference in the site that I see is that the correct page is using col2 left, and the other is col3. now these pages were custom and not in my list of cms pages, so I do not know where to change them or find them.

Not working: https://precisiondelta.com/index.php/products/ammunition.html/

Working : http://precisiondelta.com/backupold/index.php/products/ammunition.html/


1 Answer 1


I think you have mentioned wrong skin url in the secure base url in configuration. Please check in configuration->web settings in your admin panel. or somewhere missing js file.

  • I checked in Admin>Web and they seem to be as they should be. The link I gave that said Not Working has three columns when it should have two-left. I even changed the product attributes to be two column left and it did not change it.
    – Tommy
    Mar 3, 2015 at 4:37
  • Did you check the url in database? I don't think any code problem in this. I still believe you may have missed some file to place. Can you copy all the files from previous working file and check it on local server.
    – Kishor
    Mar 3, 2015 at 4:48
  • Ok, can you check all the css file as i can see you are missing some css files in your new site... open site in firefox and inspect any element and go to style editor as you can see list of css file.
    – Kishor
    Mar 3, 2015 at 5:04
  • I figured out the problem. It was right under my nose. I wasn't thinking simple enough, I had each category set to 3 column layout, once I set each category to 2 column left it worked fine. but thank you for your help.
    – Tommy
    Mar 3, 2015 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.