1

I am having difficulties to configure Magento table rate shipping method. I want to charge $15 shipping fee for orders to California and charge $25 for orders to the rest of the country.

I choosed main website in "Current Configuration Scope", then navigated to Shipping Methods, Under "Table Rates" I first export the csv file and edited it using Open Office software. Below is what is in the file:

Country Region/State Zip/Postal Code Order Subtotal (and above) Shipping Price

US, *,  *,  0,  25

US, CA, *,  0,  15

Then I went back to "Table Rates" clicked on browse button next to "import" chose the file I just finished edit, Then clicked on "Save Config". I notice there is a message next to the browse button says "no file selected".

Anyone know why this file is not uploading? Thanks for your help in advance!

1

If after uploading the file and after clicking on "save config", you are getting this "no file selected" then it is totally alright your file is uploaded. Above, on the same page you can see notice something "The configuration has been saved."

1

In response to the other answer saying not to use Open Office - I disagree with this, Open Office is fine for creating Magento csv files.

You can edit the csv settings when you save the file, just make sure the 'Edit Filter Settings' is checked;

enter image description here

Then when you are saving it I normally choose (this is a habit after lots of trial and error, it may or may not be necessary) UTF8 as the character set. The Field delimiter is a comma , and the Text Delimiter a double apostrophe ";

enter image description here

While we are discussing Open Office csv files here's a gotcha for uploading csvs via FTP for import using something like Magmi - you have to close the file on your local machine before you FTP it through a client like Filezilla or it wont upload. This may be the issue with the OP here.

0

I faced the same problem before with open office, It seemed the file got corrupted because I didn't opened it correctly. First thing I'll suggest is you re-export the file, open it with MS excel or maybe any text editor. Edit the rates over there and try to import it again. It should work.

With Open Office, take care that you use proper delimiter ie: only ( , ). It works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.