1

I have set my whole frontend to use HTTPS. But in the headers I see that if I go to http://example.com Magento redirects me to the HTTPS version using 307 redirect. I tried to change this by setting in .htaccess:

RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

but it didn't help.

What should I do to make Magento use 301 redirect instead of 307?

(I am using CE 1.9.1.0)

  • do you find any solutions? – LucScu Aug 2 '16 at 15:43
1

The 307 redirect is in real a 307 Internal Redirect done by the Chrome Browser because the domain is known to require/support Strict Transport Security

So its not done by your Magento.

See also: https://stackoverflow.com/questions/2068418/whats-the-difference-between-a-302-and-a-307-redirect/29988907#29988907

0

A typo in your sites configuration (maybe in your vhost settings for your webserver), it is nowhere defined in Magento.

Did a grep -R 307 in a clean Magento and found nothing related to your problem.

See https://stackoverflow.com/questions/2068418/whats-the-difference-between-a-302-and-a-307-redirect

  • I did that too before posting here. Strangely it seems to happen only in Chrome and Opera Chromium. – george Mar 2 '15 at 9:58
  • I found a other stack page where the answer is very clear, I think you would take a look there(edited my question) – Jeroen Mar 2 '15 at 13:04
  • Thanks. I know what redirect codes mean :) But that is not the question. – george Mar 2 '15 at 14:16
  • The answers where more specific about particular browsers – Jeroen Mar 2 '15 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.