1

I am trying to include a logo in my transactional emails. This is working but the only problem is that the logo is 633x270 and i want it to resize to 211x90 that's the only way to keep high quality images. But the problem is that just displays the logo as 633x270 way too big ofcourse...

Can anyone help me with this problem i tried a lot of things like clearing cache etc.

0

Emails have to be compatible with many different clients - webmail, Outlook etc. Golden rule - never have images that are a different size to what they need to be. You cannot rely on the email client to scale down the image to fit some width/height values in the <img> tag.

Go back to your original scaled down image and use that, 211 x 90. To solve the resolution problem scale your image carefully, don't allow a Photoshop program to make a blurry mess when resizing down. Also consider using GIF as text rendering is sharper in GIF than in JPG.

  • Thank you for your help. I am using a PNG file with the resolution 227x97 so it's ok now. Accepted as my answer. – Darren Feb 27 '15 at 11:59
0

Try to create an Transactional Email and set an width and height in the html of image.

  • Thank you for your reply! I can try that yes, but why is it not working as normal in the backoffice System > Configuration > General > Design? If i enter a width and height it just ignores it. The alt tag is working if i look at image info in email so why is the width and height not working? – Darren Feb 27 '15 at 11:16
  • s18.postimg.org/nvpqopc09/email.png You do not have the option of placing height and width here. – Eduardo Feb 27 '15 at 11:22
  • Well i have the option here: i.imgur.com/gEYsyGe.png – Darren Feb 27 '15 at 11:32
  • Maybe it is a 1.4 site... – Henry's Cat Feb 27 '15 at 11:36
  • Probably this option is from some module, apparently it does not work very well. – Eduardo Feb 27 '15 at 11:37
0

Regarding image size and scaling: Magento itself recommends (in admin backend): "To make logo look good on high-resolution displays, upload an image that is 2x normal size and then specify 1x dimensions in width/height fields below."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.