1

I have enabled captcha. From my admin panel I now have the problem that it keeps showing an invalid captcha message even when there is no captcha at the Admin Panel login page.

How can I fix it?

4

There is a possibility to enable CAPTCHA for the Admin Panel in System > Configuration > Advanced > Admin > CAPTCHA and if you have enabled it (by accident) this could be a cache issue. So try the following.

  1. Flush all Magento Cache before logging in (including your browsers cache); or
  2. Try another browser to login

To manually delete all chache use FTP or SSH to delete the following directories (if present)

[your Magento install dir]/includes/src/
[your Magento install dir]/media/css/
[your Magento install dir]/media/css_secure/
[your Magento install dir]/media/js/
[your Magento install dir]/var/cache/

IMPORTANT: Don't delete the entire includes/ media/ and var/ directories, only the subdirectories I mentioned above!

If this doesn´t help check the core_config_data table in your database to see the value for admin/captcha/enable. If the value is 1 then Captcha for Admin is enabled. You could change it to 0 to disable it.

IMPORTANT: Always make a backup of your database before making any changes!

3

My issue is the backend 'web page isn't available'.

So it's better to do by following steps:

1) disable Captcha firstly

mysql> select * from core_config_data where path like '%captcha%';

mysql> update core_config_data set value=0 where path = 'admin/captcha/enable';

2) use another browser to login backend My Chrome can't use, so i use firefox to open and signin from backend successfully.

3) use magento cache tool to flush all caches, and re-enable captcha by following sql or backend.

mysql> update core_config_data set value=1 where path = 'admin/captcha/enable';

My issues has been fixed. Hope it can help others. For all people has different environment the system, hope my experience just can be a reference.

  • I also needed to delete "var/cache/" and dissable the module at "app/etc/modules/" – Mario M. Jan 25 '17 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.