1

I really need to fix a problem with my site because it's creating reports, and then blowing out my inodes limit (250,000).

When I delete the folder and then my .trash folder, I go back to 50k inodes but the folder fills up fast again of the next day or two. Whilst that is filling up, my site will do the blank screen of death until I delete my cache folder (Mage--2).

I haven't done anything new or installed any addons etc. I'm at the point where I'll pay someone to go through my Magento site and just fix everything!

Where should I start?

    a:5:{i:0;s:0:"";i:1;s:1215:"#0 /home/fgdadmin/public_html/factory/app/code/core/Mage/Api/Model/Server/V2/Adapter/Soap.php(79): Mage_Api_Model_Server_Adapter_Soap->fault(0, 'Invalid encodin...')
#1 /home/fgdadmin/public_html/factory/app/code/core/Mage/Api/Model/Server.php(138): Mage_Api_Model_Server_V2_Adapter_Soap->run()
#2 /home/fgdadmin/public_html/factory/app/code/core/Mage/Api/controllers/V2/SoapController.php(46): Mage_Api_Model_Server->run()
#3 /home/fgdadmin/public_html/factory/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Api_V2_SoapController->indexAction()
#4 /home/fgdadmin/public_html/factory/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('index')
#5 /home/fgdadmin/public_html/factory/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#6 /home/fgdadmin/public_html/factory/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#7 /home/fgdadmin/public_html/factory/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#8 /home/fgdadmin/public_html/factory/index.php(88): Mage::run('', 'store')
#9 {main}";s:3:"url";s:13:"/api/v2_soap/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}
  • 1
    Check the contents of the reports and solve the underlying problem that causes the reports to be generated. – Anna Völkl Feb 23 '15 at 19:26
  • This is the content of the main recurring error. We recently connected our CRM to magento via an API. Is this report saying that API connection is jacked up? – Angry Aonghus Feb 23 '15 at 19:28
  • a:5:{i:0;s:0:"";i:1;s:1215:"#0 /home/fgdadmin/public_html/factory/app/code/core/Mage/Api/Model/Server/V2/Adapter/Soap.php(79): Mage_Api_Model_Server_Adapter_Soap->fault(0, 'Invalid encodin...') – Angry Aonghus Feb 23 '15 at 19:29
  • Could you just update your question with this (and maybe some more) information from the reports? – Anna Völkl Feb 23 '15 at 19:30
2

This is just a guess, but I give it a try: Your error message "Invalid encodin..." comes from the Zend_Soap_Server where Zend_Soap_Server_Exception is thrown in the run() method of Mage_Api_Model_Server_V2_Adapter_Soap.

There's a check both in the Zend_Soap_Server class if the encoding is a string. The encoding is set in Mage_Api_Model_Server_V2_Adapter_Soap method run(): $apiConfigCharset = Mage::getStoreConfig("api/config/charset");

This config is related to the following backend setting: System > Configuration > Magento Core API > Default Response Character Charset (see image below). Check if a character-set/encoding is set there and if so, which one. It might be empty. Magento Core API config

  • Im waiting to gain access to my admin section. Everything is still timing out. I think it's due to the server getting tapped out and I'm waiting on it to reset still. – Angry Aonghus Feb 23 '15 at 21:18
  • Okay my admin FINALLY let me in. It's sketchy. But my settings look just like yours. – Angry Aonghus Feb 25 '15 at 15:19
2

The reason the reports are filling up, is because your API connection between Magento and your CRM is not working. This is the root cause.

However, that being said, if you want to stop reports for the moment while you are fixing this, you can do one of the following:

  1. Turn on developer mode by adding the following code to Magento's index.php file. Note this will show the error to whoever is looking at the site. Though in this case, probably your CRM:

// In index.php, after Magento is loaded but before Mage::run(); Mage::setIsDeveloperMode(true);

  1. You can simply change the permissions of the var/report folder to prevent Magento writing to it. If you have SSH, something like:

chmod root.root var/report

If you don't have ssh access, you should change hosting, but in the meantime use FTP to set the folder as 000 (unclick all the permissions).

  • Im waiting to gain access to my admin section. Everything is still timing out. I think it's due to the server getting tapped out and I'm waiting on it to reset still. – Angry Aonghus Feb 23 '15 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.