0

I have a module which runs properly on my local instance of 1.9.1. On uploading it to a staging server, javascript that I added to the Admin Order page is running twice. After littering the files with comments, output in Chrome Dev tools shows a js file called "VM13876" that, when I click through in dev tools, is a block of js that I wrote inside a file, pulled aside into what looks like external js.

Sample output from dev tools:

RETURN Pressed                          (index):2122 
This is productGridAddSelected          sales.js:639
This is beginning of loop               sales.js:646
MADE IT THROUGH LOOP                    sales.js:655
end of productConfigureSubmit           sales.js:853
END OF  productGridAddSelected          sales.js:660 
After productGridAddSelected            (index):2140 
RETURN Pressed                          VM13876:22
This is productGridAddSelected          sales.js:639 
This is beginning of loop               sales.js:646
MADE IT THROUGH LOOP                    sales.js:655 
end of productConfigureSubmit           sales.js:853
END OF  productGridAddSelected          sales.js:660
After productGridAddSelected            VM13876:40

Does anyone know what the source of the second, "VM" js?

1

I hadn't intended for this to be a self-answered question, but as I was typing I mulled the behavior a bit and..

I thought this may have something to do with caching, so I killed the Mirasvit Full Page Cache extension, and sure enough, the VM javascript calls are gone.

Hopefully someone in the future finds this useful, as it's a bit of an odd error, but if anyone has any pointers on how to run the full page cache without it running custom Javascript twice I would definitely be interested.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.