1

I have 1 simple catalog price rule, but when I "Apply Rules" the system gets stuck and eventually I get a 500 server error:

enter image description here

These messages appear in my system.log:

2015-02-22T09:51:27+00:00 ERR (3): Warning: include(): Filename cannot be empty  in /data/home/etkm01/domains/etk-mood.nl/public_html/shop/app/code/core/Mage/Core/Block/Template.php on line 241
2015-02-22T09:51:27+00:00 ERR (3): Warning: include(): Failed opening '' for inclusion (include_path='/data/home/etkm01/domains/etk-mood.nl/public_html/shop/app/code/local:/data/home/etkm01/domains/etk-mood.nl/public_html/shop/app/code/community:/data/home/etkm01/domains/etk-mood.nl/public_html/shop/app/code/core:/data/home/etkm01/domains/etk-mood.nl/public_html/shop/lib:.:/usr/local/php5/lib/php')  in /data/home/etkm01/domains/etk-mood.nl/public_html/shop/app/code/core/Mage/Core/Block/Template.php on line 241

And this is a part of template.php:

238      try {
239           $includeFilePath = realpath($this->_viewDir . DS . $fileName);
240           if (strpos($includeFilePath, realpath($this->_viewDir)) === 0 || $this->_getAllowSymlinks()) {
241                include $includeFilePath;
242            } else {
243                Mage::log('Not valid template file:'.$fileName, Zend_Log::CRIT, null, null, true);
244           }

Unfortenately I don't have enough knowledge to know what to do.

  • Did you checked the log files in var/log or var/report? Can you see any errors there? – Marcel Hauri Feb 22 '15 at 9:29
1

This error happens, when you try to use templates which are symlinked and the "Allow symlink" option under System > Config > Developer is No.

The second idea I have is, that you run into a max_execution_time out

  • "Allow Symlink" was set to "Yes" and max_execution_time is set to 90. I still get the 500 server error and the error message in system.log is still the same. – lidacha Feb 22 '15 at 10:43
  • Just stop the time, do you get the 500 error after 90 seconds? If yes, raise the limit – Fabian Blechschmidt Feb 22 '15 at 18:36
  • I timed it and it was exactly 2 minutes. I then raised the max_execution_time to 300, and again, it took exactly 2 minutes for the error to appear. – lidacha Feb 22 '15 at 19:06
  • No offence, but are you sure about your 90 seconds? Read it from phpinfo() or from php.ini? :-) I ask because the max_execution_time is set in .htaccess (again) – Fabian Blechschmidt Feb 22 '15 at 19:30
  • Oh, no, I obviously miss knowledge, so glad you asked! --------- php.info(): max_execution_time 90 (local value) 90 (master value) --------- php.ini: max_execution_time = 300 ; Maximum execution time of each script, in seconds (originally 30) max_input_time = 60 ; Maximum amount of time each script may spend parsing request data max_input_vars = 10000 memory_limit = 1024M ; Maximum amount of memory a script may consume (128MB) (originally 128) --------- .htaccess: php_value memory_limit 256M php_value max_execution_time 18000 php_value max_input_vars 1000 – lidacha Feb 22 '15 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.