3

I just noticed when trying to flush cache storage through the admin in Magento Enterprise 1.13.1 for one of our clients, it isn't flushing the database set in the Redis configuration for FPC. I notice in the method clean, this is called when the cleaning mode is set to all.

 $this->_redis->flushDb();

shouldn't it be $this->_redis->flushAll();

or loop over all of the dbs setup in the configuration of local.xml and flush each database. I haven't noticed this before but maybe it was because I always did it through a script or command line. But our client needs to be able to do it from the admin panel.

I saw this in another thread and may install it but I am trying to understand if there is something I am missing first about the FPC db flushing through default Magento https://github.com/steverobbins/Magento-Redismanager

closed as too broad by brentwpeterson, Rajeev K Tomy, Amit Bera, Marius Mar 6 '15 at 7:19

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Have you tried to debug this? Is there anything relevant in the redis logs? – Reid Blomquist Feb 21 '15 at 18:35
  • 1
    I have tried to debug, there isn't anything in any logs and I have done redis-cli | grep flush and when I do that I see that it only flushes flushDb(1) – dan.codes Feb 21 '15 at 20:46