3

When I click on an attribute set to edit/configure it, Magento loads an empty page. I have searched on here and Google to find a solution, and have tried changing the memory_limit and max_execution_time with no success.

The page I see has the Magento Admin Panel header/footer with all the CSS, but in-between is empty.

I have also tried flushing the cache, etc.

I am using the latest version of Magento 1.7 Community Edition. The PHP version is 5.2.17.

I have tried enabling error logs, but log files don't seem to be generated - there is nothing in /var/log. The permissions on the /var/log directory are correct.

I tried the solution in http://www.magentocommerce.com/boards/viewthread/226412/#t424303 but it didn’t make any difference.

I can't view PHP / Apache server logs as its on shared hosting and they won't allow it.

I also tried using Firebug in Firefox to solve the issue, but got this error: [21:06:05.016] The Web Console logging API (console.log, console.info, console.warn, console.error) has been disabled by a script on this page.

Any help would be appreciated.

  • Can you follow this and re-try? sonassi.com/knowledge-base/magento-debug-process – Ben Lessani - Sonassi Feb 7 '13 at 17:33
  • SetEnv MAGE_IS_DEVELOPER_MODE true didn't seem to make any difference in terms of getting more info. Adding the stuff to .htaccess for /var/logs gave me an Internal Server Error when trying to access the Magento Admin Panel. – user467 Feb 7 '13 at 18:16
  • 1
    When you have a white page - there is a PHP error in the block - which has been caught and not displayed. The error will be shown if you enable developer mode and errors - or enable error logging. – Ben Lessani - Sonassi Feb 7 '13 at 18:21
  • Error logging is already enabled, but logs are not being generated - this is one of the problems. Adding the stuff to .htaccess to enable logging, resulted in an Internal Server Error when trying to access the Admin Panel. – user467 Feb 7 '13 at 18:24
  • 3
    when the log is not written, it is normally because it lacks permission. Magento then falls back to /tmp/magento. check the permissions and check wether /tmp/magento/var/log/ contains any log :) – Fabian Blechschmidt Feb 9 '13 at 12:30
1

It might be a design package issue. We had something similar in another setup of ours and it rendered some of our admin panels empty due to some admin panel changes.

Go to System->Configuration->General->Design. Check what the package/theme is under default configuration. Is it not the default for Magento? If so, you may have a theme doing some unintended stuff.

Turn on template hints in the admin panel. (Tutorial) Check to see what templates are being loaded in these hints and see if there is anything that seems out of place with the rest of the templates.

0

Are you positive it's not a front end javascript error of some sort? Half formed admin interfaces are often caused by that. I'd look at your JS error console first. I usually use Chrome with the dev tools open to the "Network" tab and make note of any JS files that have not loaded for instance.

Also there is some info about enabling firebug console. http://blog.kyp.fr/a-tutorial-to-enable-firebug-console-log-in-magento/

You could try enabling query and error logs on mysql to see what the queries were.

As others have said many times you are really handicapping yourself by using shared hosting with magento ESPECIALLY when they won't even give you access to your error logs. I'd highly recommend you use just about any VM hosting that gives you root access. It will be much less frustrating as well as performant.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy