1

Today, my Magento Downloader won't work. It worked for installing extensions previously, but today I get: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure. It seems the issue is on Magento Connect, but I don't see other reports of the issue.

Magento 1.9.1

  • 1
    Is your server still running sslv3? Do you have access to your own web server config? If so you can try disabling sslv3 and switching to tlsv1. – seanbreeden Feb 19 '15 at 23:09
  • I have the same problem ! With my magento 1.9.1 It was working before and I changed nothing on the server. – user22640 Feb 20 '15 at 0:15
  • “This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation.” – Rajeev K Tomy Feb 20 '15 at 0:45
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – Rajeev K Tomy Feb 20 '15 at 0:45
  • These comments may not be "answers", but they do point to a wider problem than just me. My dev setup worked just fine prior to yesterday, and then I was receiving this error. I will look at my server setup, per the suggestions, but that does not explain WHY it previously worked, then did not. – Craig Feb 20 '15 at 15:02
1

If you have received a version of the: error: 14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure! error while trying to install a Magento Connect extension, it's because Magento turned off SSLv# on Magento Connect, but curl is still trying to connect with SSLv3.

Here is a solution and a patch file I came up with a few days ago. I wrote a post about it on our blog and explaining how to patch it: https://www.dwdonline.com/blog/fix-magento-error14077410ssl-routinesssl23_get_server_hellosslv3-alert-handshake-failure.html

  • Perfection! Following your blog. Hoping this fix makes its way into the next release. Thanks for responding. – Craig Feb 23 '15 at 15:11
  • Glad it helped! It wouldn't let me post an answer earlier (had to get a higher reputation). – Philip Deatherage Feb 23 '15 at 19:29
2

I have the same problem, for a temporary solution: you can download the source files directly off of MagentoConnect using this tool:

http://freegento.com/ddl-magento-extension.php

and then upload them manually!

  • While not a final answer, this helps tremendously. Thanks! (Unfortunately, I lack the "rep" to upvote this response) – Craig Feb 20 '15 at 15:08
1

Same problem here, everything is fine on the my development site installed locally (running on MAMP) but nothing on the live website (centos w/cpanel & whm)

here is the apache config

  • SSLv2 Disabled
  • SSLv3 Disabled
  • TLS 1 Enabled
  • TLS 1.1 Enabled
  • TLS 1.2 Enabled

protected by Community Feb 20 '15 at 12:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.