4

I am using magento 1.5.1.0 and I want to install patch SUPEE-5344. When I check the download page of magentocommerce.com I can only find the patch for Magento-CE-v1.4.0.x-1.5.0.x

Will this version support version 1.5.1 ? or does it only support up to version 1.5.0.x ?

Thanks for your input

  • Three files are repaired in that patch => app/code/core/Mage/Admin/Model/Observer.php, app/code/core/Mage/Core/Controller/Request/Http.php and lib/Varien/Db/Adapter/Pdo/Mysql.php. Running a diff shows there were major changes between 1.5.0.1 and 1.5.1.0. I didn't check to see if there were changes between 1.5.1.0 and 1.6.2.0. If you could go decompress those two install archives, you could diff the files to see if they're alike. – Fiasco Labs Feb 18 '15 at 7:22
  • 1
    You should upgrade your Magento store anyway, because I think only major security issues are fixed with a patch also available for older versions. Smaller security issues are only fixed with new versions. – Simon Feb 18 '15 at 17:36
4

The patch for 1.5.1.0 was erroneously left out of the list (yes, I find this alarming too). I've opened a ticket to have the patch added, but in the meantime I can email this to anyone who would like it. Just let me know (As a moderator I can see your email) or send me a request at ben.marks@magento.com.

  • Thank you for thanking me, but please know that I think we should be doing a better job at communicating these kind of differences than we are. – benmarks Feb 23 '15 at 0:18
3

The patch is now available from the official download page. When you download the patch SUPEE-5344 for CE 1.5.1.0 the filename is PATCH_SUPEE-5390_CE_1.5.1.0_v1.sh. Don't wonder, that's okay. Also see SUPEE-5344 - Addresses a potential remote code execution exploit for a list of the filename in all versions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.