2

I am trying to install a magento extension via connect and i keep getting the following error.

CONNECT ERROR: Package file is invalid
'./app/etc' already exists

If i unzip the extension i can easily do a manual install and it works perfectly.

Did anything change between 1.8 and 1.9 that causes this problem ?

I also have write access to the directories.

Edit: I am trying to install this on CE 1.9

My package.xml was missing a few details this was my problem

2
  • I had problems with my magneto connect as well. Its best to have the latest version.
    – Jeffery B
    Commented Feb 17, 2015 at 19:23
  • I figured out the problem, my package.xml file was missing a file element.
    – Amit Vig
    Commented Feb 18, 2015 at 18:24

1 Answer 1

1

Try this:

To resolve this problem just navigate to Settings and find Magento Connect Channel Protocol:

You have to change it from HTTP to FTP!

This will resolve your problem.

Tested and working, please if it works for you mark my answer as an answer for your question!

2
  • If this is the real answer, I vote that error message to be the worst diagnostic ever.
    – user4351
    Commented Feb 17, 2015 at 19:54
  • I figured out the problem, my package.xml file was missing a file element.
    – Amit Vig
    Commented Feb 18, 2015 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.