2

Myself and my developer are having issues trying to force Magento to use https for all links and add the www. before our website domain.

Currently, if you go to www. thepoultryhatchery .com it will automatically drop the www. we Want the www., how do we fix that? We also have an SSL certificate, which gives us the "green bar".

If you use the https:// in front of the domain above, it messes up the sites layout.

If you just go to thepoultryhatchery .com and click the login button in the top upper right hand corner, you will see it will force http on the login screen but errors still happen.

Godaddy does not support Magento, so he gave me this url called whynopadlock .com/ and when you copy and past the login url:

https://thepoultryhatchery.com/storpickup/index.php/customer/account/login/

it tells you whats wrong but we cant seem to fix this issue.

We've previously tried to go into system --> configuration --> Web --> (see attached screenshot).

When we tried to change the url to www. and add the https we got a 404 error and couldnt access the website period. We had to go in the database and change from 1 to 0 or something of that such to regain access.

How do we properly force https for all pages, both stores, front end and backend. and make sure all links display www. in front of the domain. so all urls should look like https:// www. ThePoultryHatchery .com

please provide as many details, new to magento.

Any help would be greatly appreciated! Ps. We are on Magento Community ver. 1.9.0.1

Thanks so much!

  • If URLS dont work, remove space, due to reputation i could only post 2 urls.. dumb rule... – Jeffery B Feb 17 '15 at 18:08
  • 1
    A 404 error after adding the www to your base URLs could indicate improper configuration on the DNS level. You might need to verify an A record for www. Also, are you running anything through a CDN? – Rick Buczynski Feb 17 '15 at 18:12
  • Change your base and secure url to http://www... – Renon Stewart Feb 17 '15 at 18:14
  • @R.S if i just change it, when i clear cache it locks me out is there a 2nd step i need to change in database too? or does it automatically edit it? – Jeffery B Feb 17 '15 at 18:19
  • Explain "locks me out" – Renon Stewart Feb 17 '15 at 18:22
2

Some general advice here:

  • Revert your theme to base/default or rwd/default (or some other "out of the box" theme) and check to see how things look. This will at least give you some clues on what to fix.
  • You have loads of assets that are trying to load over http instead of https. Your custom theme might be hard-coded to call assets with http. Again, switching to a base theme will give you clues here.
  • Make sure your DNS records are set properly and that you have an A record for www.domain.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.