0

I'm trying to set up Fedex on the site and it is not showing up during checkout. I have the Fedex option enabled in backend with applicable keys and passwords and such, obviously. I tried flipping on and off the residential delivery. Show method if N/A is true. It is set to debug and has an error message that should show... I made sure logging was enabled under developer tag... and I even did the following per advice found here:

In file app/code/core/Mage/Usa/Model/Shipping/Fedex.php approx line 409: // find: $responseBody = curl_exec($ch);

// add: Mage::log($responseBody);

I flushed cache and reindexed. Tried to go through checkout, and the only options showing are UPS. There is no error message, and nothing is logging in system.log or exception.log. Any ideas?

Fedex settings

2

I didn't realize that the server wasn't logging anything. Changed all files and folders in var to 777 and gave ownership back to server. Then my products did not have a weight assigned to them. As soon as I assigned a weight, the Fedex options show up during checkout.

2

This answer may not help you, if other shipping methods show up OK, but I found a fix for a similar problem today.

Products need a weight assigned to them, as CaitlinHavener pointed out. These weights also need to be less than the Weight Maximum allowed by the shipping method.

We had some test data with products weighing 200lbs when the FedEx maxed out at 150lbs. I dropped the products to a sane 10lbs and now it's showing up as expected.

Hope this helps a fellow Google'r!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.