0

As I reinstalled my theme, I created a folder installed under the public folder. Here I uploaded all the installation files for the new theme. This went as a new Magento installation and not just adding files to an existing Magento. I was hoping, I could install the new Theme + Magento into the public_html folder but instead it was all installed under the "install" folder. Now my the site only works under "mydomain/install/" while I want "mydomain" only. How can I correct this? Should this be done at the back end under CMS Home pages?

  • 1
    No.. It can be done by pointing your domain name to ../public_html/install. Change the DocumentRoot in your vhost file – Girish SH Feb 17 '15 at 8:21
  • This sound to me the fasted way but how to do this? Before doing this is it first possible to rename the install folder to my domain name, just for the cosmetics and than change the Vhost file? But where to find this file? – Bobby Feb 17 '15 at 8:52
  • @GirishSH please add that as an answer. Preferably with an example vhost snippit. It's a good one – Sander Mangel Feb 17 '15 at 9:35
  • @Sander Ok Sure, I will add it as answer. – Girish SH Feb 17 '15 at 9:40
1

You can move the files from the install folder to the root folder via FTP.

The only thing you need to change after that is the table rows with path web/unsecure/base_url and web/secure/base_url in the conre_config_data database table. These should be the value http://domain.com/ instead of http://domain.com/install/

  • I have tried this but this doesn't work unless there is a missing link. As soon when you move all files via ftp you don't get access anymore to your back-end and can't edit the database table. I still sees the Mydomain/install/ path where it expects the index file to be. I than reversed and before I move via FTP I first changed the database secure and unsecure. Also that didn't work. – Bobby Feb 17 '15 at 9:29
  • Hm either there are several base_url fields or the baseurl is hardcoded in app/etc/local.xml, your htaccess or index.php – Sander Mangel Feb 17 '15 at 9:35
  • This was not a good idea as now I cant get anymore to my back-end and change the base-url back to install. Seems like I have to delete all and start over. – Bobby Feb 17 '15 at 9:40
0

Point your domain name to ../public_html/install/ instead of ../public_html

For that you need to change the DocumentRoot in your vhost file.

<VirtualHost *:80>
ServerAdmin webmaster@localhost
DocumentRoot /path_to_your_public_html/public_html/install/
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

In the above code, You need to change the DocumentRoot line.

If you are using the cPanel, In addon Domains options you can find the settings : As shown below

enter image description here

  • I believe you want to say point your domain to ../public_html/ instead of ../public_html/install/ Now what is the document root? I assume I have to edit this file. Where is that file located? – Bobby Feb 17 '15 at 9:53
  • No.. You should change it to ../public_html/install/ from ../public_html/.. Which OS you have in server? – Girish SH Feb 17 '15 at 9:55
  • apache. Yes I can create it as a subdomain at the Cpanel. So the new Domain name will be mydomain and the sub domain mydomain/install. is that correct? – Bobby Feb 17 '15 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.