0

I convert an xml file to .csv based on a freshly installed magento's export via dataflow.

After that i changed my product.csv with all required attributes and made magmi import.

All cool but when i try to go some product page from home page like http://185.22.187.222/index.php/kopek-dis-kasima-oyuncagi-petstages.html

site appears corrupted. Im adding my csv file so if you guys want to help me i'll be thankful!

You can also check backend if you want to login information, just send a mail or add me in skype "agnahie" and yayilanradyasyon@gmail.com

It makes me crazy... Probably the problem is my stupidity.

Here is the link for newly generated csv file; http://www.megafileupload.com/en/file/609298/products--4--csv.html

  • I can not open the link to your product (always redirects me to the front page), but from your CSV I would guess that it's either something in the custom_design column (you can just delete this column, Magmi does not need it) or maybe the line-breaks in your HTML code in the description-column – simonthesorcerer Feb 16 '15 at 1:23
  • This is solved my problem thank you so much! – Solemtech Feb 16 '15 at 1:33
  • No problem. I'll add it as an answer. Was it the custom_design or the other stuff? – simonthesorcerer Feb 16 '15 at 1:33
  • it was custom_design attribute. It has been set default/default. First i changed "mythemename/default" it worked too, but then i just simply deleted it. Now it worked perfectly. But i use category trees as you can see to import categories. It occurs an url rewriting problem at backend and i have to set url rewrite "no" to view products normally on frontend. Do you have any solution for this too? – Solemtech Feb 16 '15 at 1:52
  • Hm, this has always worked well for me. What problem occurs in the backend? Do you use categories in your product urls? Sounds like reindexing issue to me. Also, do you have flat tables enabled? – simonthesorcerer Feb 16 '15 at 1:56
1

I can not open the link to your product (always redirects me to the front page), but from your CSV I would guess that it's either something in the custom_design column (you can just delete this column, Magmi does not need it) or maybe the line-breaks in your HTML code in the description-column

| improve this answer | |
0

Turn of compilation mode under Admin -> System -> Tools -> Compilation. Reindex your site completely at Admin -> System -> Index Management. Flush all of your Magento cache at Admin -> System -> Cache Management.

| improve this answer | |
  • COmpilation is off. I already indexed and flushed cache :) – Solemtech Feb 16 '15 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.