5

I need to ask about how to set up a simple product to be able to show it to my configurable associated products.

I think I already configure all the attributes like,

  1. visibilty = not show inidividually
  2. stock = in stock
  3. attribute set = the same as configurable product
  4. price = also set
  5. status = enable

anything I missed? Because when go to my configurable product some of my simple products created wouldn't show up as Associated Products.

  • How did you create the simple products? Make sure that they are associated to the configurable product. Go into the configurable product, select the 'Associated Products' tab and see if all simple products are associated correctly. – Simon Feb 14 '15 at 13:20
  • My simple products are the same attribute set as configurable product. But one my simple products is not showing up in associated tab. I cant find the simple products in there. What do you think happen? – Yves Gonzaga Feb 14 '15 at 15:29
  • I had a similar problem and for some reason I could only get around it by making the first associated product with the "Create Simple Associated Product" detailed form, rather than the "Quick simple product creation" section. After that, quick creates worked. – Jonathan Sep 5 '15 at 14:12
  • @YvesGonzaga @ Your configurable attributes needed to be set to Apply To "All Product Types", not just configurable. haven't tried but maybe even just selecting "Configurable and Simple" products. – johnsnails Oct 14 '15 at 3:18
4

Make sure that you associated the simple products with the configurable product. Therefore, go to the configurable product, open the "Associated Products" tab, select the appropriate simple products and save. If you do not see your simple products there, make sure to click on "Reset Filter" (and that your simple products have the same attribute set as your configurable one). As always, you may need to reindex or clear your cache.

  • 1
    That is my problem. In my associated tab I cant find the simple products in there. What do you think happen? – Yves Gonzaga Feb 14 '15 at 15:32
  • @YvesGonzaga see my edited answer above. – Simon Feb 14 '15 at 15:41
  • 1
    LOL your right that "reset filter button" in there. I haven't use it because I thought when I reload the page the associated products will reload too. I think there's some special function on that "reset filter" button. Thank you so much. – Yves Gonzaga Feb 14 '15 at 22:24
  • Even with the filter reset (and the left one set to "any") I can only see products that are already associated with it. – Mike May 11 '15 at 18:04
  • 2
    @Mike Your configurable attributes needed to be set to Apply To "All Product Types", not just configurable. haven't tried but maybe even just selecting "Configurable and Simple" products. – johnsnails Oct 14 '15 at 3:18
4

To associate them

not needed:

  • visibilty = not show inidividually
  • stock = in stock
  • price = also set
  • status = enable

needed:

  • attribute set = the same as configurable product

to create a config

Beside this you need to make sure, that the attributes you want to be configurable are NOT system, "Global", input type "Dropdown" and "allowed for configurables"

to show them in frontend

Only the simple ones which are in stock and enabled are shown in frontend, might be an indexing issue?

  • My simple products are the same attribute set as configurable product. But one my simple products is not showing up in associated tab. I cant find the simple products in there. What do you think happen? – Yves Gonzaga Feb 14 '15 at 15:30
  • May it be the 21th, so it is on the 2nd page? – Fabian Blechschmidt Feb 14 '15 at 20:53
  • Nop. I have only 9 attributes. – Yves Gonzaga Feb 14 '15 at 22:19
  • 2
    Also: If the simple products have their own custom product options, they won't show in the associated products list – snez Nov 24 '15 at 17:22
2

Also, if you do not see the products in the associated tab, even after resetting the filter, check that the attributes that are configurable, have a correct value in the simple product. I loaded lots of simple products via import, but for some simple products the color or size attributes were empty and could not be found. Make sure all attributes that are marked in the configurable products as "configurable" are filled.

0

Make sure that you have something the the SIZE attribute of the simple or whatever the configurable atribute is (colour etc). If it's blank, the simple will NOT appear in the list of products to attach to the CON.

0

I also found that some of the simple products I added via Quick Simple Product Creation in Associated Products, while creating the simple product did not apply the attribute. Therefore, they did not display in the list of associated products.

I may have forgotten to select the correct attribute in the dropdown before clicking "Quick Create".

I had to go into the simple product/General tab and all the way down at the bottom of that page, select the corresponding attribute. Once I did that, the missing simple products showed up in the Associated Products list under the configurable product.

0

The issue occurs when you create an attribute. In the attribute drop-down section, it is important to choose "apply to all products". It is not enough to choose a "configurable product".

So edit your attribute and save. Now head over to your configurable and create associated products.

In case you have already created associated products which only do not show up in the list, click "associated products" and change the dropdown value from "yes" to "any" and search for your associated simple products. By clicking the checkbox of a product it will be added to the list of associated products permanently. And now your product should be visible in the frontend.

Remember. the conf product has to be visible in catalog and search. Associated products have to be set to "not visible individually".

0

Everything was setup but products were not showing I just run below commands that solved problem.

php bin/magento indexer:reindex

php bin/magento cache:flush

php bin/magento cache:clean

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.