0

I created a configurable product with its associated products. I added two attributes in the way that magento tutorial suggested.

When I go to the product page http://www.youbigtees.com/index.php/t-shirts/test1-tshirt.html

You can see the product attributes are there and I select one of each and hit add to cart - NOTHING happens.

Its driving me nuts .. can someone help - please?

1

Look in your theme's catalog\product\view.phtml. You have a line of javascript that is bad.

$('ma-pro-options').appendChild($('ma-related-pro'));

The first selector should be $('#ma-pro-options') since ma-pro-options is an ID. I'm not sure what the selector inside the appendChild is exactly, but that probably needs to be changed as well. For testing purposes, you can delete this line and your add to cart should work after that. I know this doesn't completely solve your problem, as this removes whatever functionality you are trying to accomplish, but it should put you on the right track.

  • $('ma-pro-options') is actually correct in prototype to select elements by ID. – Vinai Jul 10 '13 at 14:35
1

I agree with @airhorse, you have JavaScript issues. I'd suggest reading this answer: https://magento.stackexchange.com/a/4436/1956 as it will describe some basics for troubleshooting JavaScript issues with your Website.

So one thing to keep in mind is all interactive functionality on the front end of your Website ( form selections/submissions, sliders, DOM manipulations ( https://developer.mozilla.org/en-US/docs/DOM ), AJAX, etc ) are done via JavaScript. So if you can clearly see that one of the above aforementioned functionalities aren't working, then there are most likely JavaScript issues somewhere.

If you have a JavaScript error ( syntax error, a resource didn't load that code within the page depends on, runtime error, etc ) then your page will just not work until that is resolved.

That said, looking at my JavaScript console in Chrome Dev Tools, I see the following errors:

Failed to load resource http://s7.addthis.com/js/250/addthis_widget.js#pubid=xa-4ebf9cd355b286dd
Uncaught Error: NotFoundError: DOM Exception 8 test1-tshirt.html:551

So, airhorse was correct regarding your syntax error of leaving out the hash (#) in your id selector ( http://api.jquery.com/id-selector/ ). But there's also the issue of the addthis_widget.js file not loading up correctly. So, you have at least two JavaScript problems here.

You'll need to refer to the addthis.com Developer Documentation for this JS button: http://support.addthis.com/customer/portal/articles/381263-addthis-sharing-button-api for more details on what you need to do to correctly call on the JavaScript file.

I hope this is helpful, and helps your resolve this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.