1

I am using magento 1.8.1 and moved my site from localhost to live site for some reason it was redirecting to my localhost itself so i changed my site url in both web_base_secure and unsecure url from core_config_data table in database with no luck still it was redirecting to my localhost and then i tries deleting contents in var/cache folder my site stopped redirecting but loads as shown in image.

enter image description here

For some reason i couldn't login to my admin page the same page appears if try to load my admin page.

Please help me this problem is killing me.

Thanks in advance......

eb 12 07:27:28 2015] [notice] caught SIGTERM, shutting down
[Thu Feb 12 07:27:28 2015] [notice] Apache/2.2.22 (Ubuntu) PHP/5.4.37-1+deb.sury.org~precise+1 configured -- resuming normal operations
[Thu Feb 12 13:44:44 2015] [error] [client 61.240.144.66] File does not exist: /var/www/wildrose
[Thu Feb 12 14:34:14 2015] [error] [client 202.83.25.123] File does not exist: /var/www/wildrose
[Thu Feb 12 14:34:15 2015] [error] [client 202.83.25.123] File does not exist: /var/www/wildrose
[Thu Feb 12 14:34:21 2015] [error] [client 202.83.25.123] File does not exist: /var/www/wildrose
[Thu Feb 12 14:34:25 2015] [error] [client 202.83.25.123] File does not exist: /var/www/wildrose
[Thu Feb 12 14:34:51 2015] [error] [client 202.83.25.123] File does not exist: /var/www/wildrose
[Thu Feb 12 14:37:36 2015] [notice] caught SIGTERM, shutting down
[Thu Feb 12 14:37:37 2015] [notice] Apache/2.2.22 (Ubuntu) PHP/5.4.37-1+deb.sury.org~precise+1 configured -- resuming normal operations
[Thu Feb 12 15:24:34 2015] [error] [client 62.210.127.243] File does not exist: /usr/share/phpmyadmin/scripts
[Thu Feb 12 15:38:15 2015] [notice] caught SIGTERM, shutting down
[Thu Feb 12 15:39:05 2015] [notice] Apache/2.2.22 (Ubuntu) PHP/5.4.37-1+deb.sury.org~precise+1 configured -- resuming normal operations
[Thu Feb 12 15:46:21 2015] [notice] caught SIGTERM, shutting down
[Thu Feb 12 15:46:21 2015] [notice] Apache/2.2.22 (Ubuntu) PHP/5.4.37-1+deb.sury.org~precise+1 configured -- resuming normal operations
[Thu Feb 12 16:14:48 2015] [notice] caught SIGTERM, shutting down
[Thu Feb 12 16:14:49 2015] [notice] Apache/2.2.22 (Ubuntu) PHP/5.4.37-1+deb.sury.org~precise+1 configured -- resuming normal operations

Note: I noticed that my site is always pointing towards no route page how to overcome this please help me.

3
  • Check you have the correct access rights on the folders as well as the folders have been given the correct user / group. Normally you should always change the URLs in core_config_data and delete the cache BEFORE you try and load the site.
    – tecjam
    Feb 12, 2015 at 15:43
  • Check your server error log Feb 12, 2015 at 15:55
  • @R.S updated with error logs.
    – megamage
    Feb 12, 2015 at 16:27

2 Answers 2

1

It looks like your assets (in your skin folder) are not loading.

Check your page's source. Check the links to CSS, images, etc. Does it look like this?:

http://www.yourdomain.comskin/frontend/package/theme...

If this is the case, you are missing a trailing slash (/) in your web/unsecure/base_url or web/secure/base_url in your core_config_data table in your database.

6
  • i checked it's correct only i have given trailing slash.
    – megamage
    Feb 12, 2015 at 16:42
  • Could you paste an example of your page source? A snippet with the assets would suffice. Feb 12, 2015 at 16:42
  • No i checked my source page it looks like xxx.xxx.x.xx/new/skin/frontend/theme/default/…
    – megamage
    Feb 17, 2015 at 10:35
  • Is your new website located in the 'new' folder on webserver?
    – Dmytro
    Feb 17, 2015 at 10:45
  • @Dmitry yes it is located in new folder but if u inspect and see none of the js,css,image gets loaded. But every url is right in source page. I have given even full permisssion but no luck. I do know why it always points to no route page instead of home page.
    – megamage
    Feb 17, 2015 at 10:54
0

The answer was very simple, the mistake i made was overriding the folder name twice in both virtual host and in database web/secure/base_url and web/unsecure/base_url and most importanly while dumping your database please open the sql file in notepad editor and change all the old links to your new link and then delete your var/cache folders.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.