1

Logging into the Magento Connect Manager, I've added the Extension Key from Magento Connect, and clicked "Install". For 0.2-0.5 Seconds, the "Please Wait" box flashes up then promptly disappears.

Nothing else happens at all. It happens whichever extension I try to install.

Very odd.

The store is v. 1.8.1.0 installed on CentOS

Could any body shine any light upon this at all, or suggest where I might look for more information.

1

Run the Magento requirements check to make sure that you aren't missing anything:

http://www.magentocommerce.com/knowledge-base/entry/how-do-i-know-if-my-server-is-compatible-with-magento

  • Thanks for this, checked it and (un)fortunately it all looks fine - the site is installed and running fine, it really is just that it's refusing to accept any more extensions. – Wren Feb 12 '15 at 15:29
0

You might got some error like that or saying "The connection string is empty" what you can do is check permission of files & folder inside magento.

  • Just temporarily changed permissions to 0777; alas no luck, still not doing anything... Thanks for the suggestion though! – Wren Feb 12 '15 at 16:51
0

It seems some of the files might be missing from the downloader folder. Please copy the downloader folder from the fresh magento1.8 folder structure and replace it on your website.

Once done, check for the files and folder permissions. It should work for you. Please keep the backup of the old folder though.

0

I had similar problem with Magento 1.9.1, when extension was downloaded, but not installed.

No permission or other setting I found on net helped, but copying the downloader files from fresh Magento installation fixed the problem, as Dexter mentioned for 1.8.

0

i was facing the same problem i did clear the cache and things were fine. it started to work. a cache file was creating this error. Hope it works for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.