0

I tried re-indexing with script reindexing.php file in root Reference:

<?php
 require_once 'app/Mage.php';
 $app = Mage::app('admin');
 umask(0);
 for ($index = 1; $index <= 8; $index++) {
    $process = Mage::getModel('index/process')->load($index);
    $process->reindexAll();
}
?>

And on running this it shows me this error: Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[42000]: Syntax error or access violation: 1118 Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. You have to change some columns to TEXT or BLOBs' in /home/ccg/public_html/lib/Zend/Db/Statement/Pdo.php:228

I First tried reindexing from backend which doesn't reindex Product Flat Data ? How to fix this issue, how to know the 1118 Row ? and change the row type ?

Also, if i disabled product flat data, does that support for products while importing from CSV File ?

1

I believe this has already been answered here

The key part from that issue:

This can be fixed by removing any attributes that you do not need to appear in the product flat data table by turning off the following attribute properties: Used in Product Listing and Used for Sorting in Product Listing and then attempting a reindex when you've reduced the character count to below the limit.

  • or alternatively not using flat product data, and implementing some full page caching to reduce load on the database. – Andrew Kett Feb 12 '15 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.