1

I've just made a fresh installation of Magento 2 (Magento ver. 0.42.0-beta7). I've noticed that in the backend, the top navigation menu is not working (Sales, Products, Customers). Also when I try to switch the store view, I get a good number of javascript errors as follows:

enter image description here

I saw this behavior on both Chrome and Firefox.

Also, if I go to my Magento installation and go to pub/static/adminhtml/Magento/backend/en_US, I don't find the jquery folder. That explains the 404 errors for the javascript files.

Has anyone met this problem?

Thanks,

5
  • Are you sure all folders are writable and the permissions were correct during installation?
    – Niels
    Feb 11, 2015 at 11:52
  • I've tried re-installing giving 777 permissions but still to no avail. I've installed beta2 now and it's working.
    – Krt_Malta
    Feb 11, 2015 at 12:55
  • 1
    Is this related to this issue reported on the Magento 2 official GitHub? github.com/magento/magento2/issues/1016
    – 7ochem
    Mar 23, 2015 at 8:18
  • Problem still exists beta-19 four solid hours of clearing cache, fixing less issues, debugging script loading errors before I finally called it ... not looking good for the mage 2 team...rm -rf /magento Jul 11, 2015 at 5:24
  • 4
    I'm voting to close this question as off-topic because it is related to a pre stable version of Magento 2: meta.magento.stackexchange.com/questions/907/… May 18, 2016 at 8:50

1 Answer 1

2

Remove content of pub/static/_requirejs/* directory. I had similar issue after upgrading to beta7 and in my case it helped.

Maybe also delete content of following ones:

  • var/cache/*
  • var/page_cache/*
  • var/generation/*

Not the answer you're looking for? Browse other questions tagged or ask your own question.