1

I've a fresh installation of Magento ver 1.9.1.0 on localhost. I'm following this tutorial closely to create a child theme of Magento responsive theme.

I've followed all steps clearly. I've created Magento directory structure, using this approach

[Magento Directory]/app/design/frontend/{package_name}/{theme_name}/etc

and created theme.xml file there. As can be seen enter image description here

Exact location of the theme.xml file is:

[Magento Directory]/app/design/frontend/tutsplus/vstyle/etc

as my package name is 'tutsplus' and theme name is 'vstyle'. I've also correctly enabled this theme from admin panel. As can be seen in below screenshot:

enter image description here

The code of theme.xml file is:

<?xml version="1.0"?>
<theme>
    <parent>rwd/default</parent>
</theme>

Can someone point out what am I missing?

1

Your screenshot from the design tab in the configuration is not complete. Setting vstyle only under the templates section is not enough. You have to define it under templates, skin and layout or just under default.

0

Everything looks good. Did you clear the Magento cache? Any change to XML files requires the cache to be cleared.

  • All cache is already disabled, still I've flushed Magento cache, but to no avail. Page still appears broken with no css styles. – anwartheravian Feb 9 '15 at 0:41
  • On the tutorial I'm following it is written: If styles.css is loading from a path similar to the following, theme.xml is most likely not loading. http://www.example.com/magento/skin/frontend/base/default/css/styles.css This is precisely the problem I'm facing – anwartheravian Feb 9 '15 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.