1

I have worked on localhost. It was good in localhost, but not in antoher server.I installed my magento file in the server and setup the database. But when i open the site it show the error message like bellow

There has been an error processing your request

SQLSTATE[28000] [1045] Access denied for user 'tqbasein_collect '@'localhost' (using password: YES)

Trace:
#0 /home1/tqbasein/public_html/c/collectivecraft/WebSite/lib/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /home1/tqbasein/public_html/c/collectivecraft/WebSite/lib/Varien/Db/Adapter/Pdo/Mysql.php(313): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /home1/tqbasein/public_html/c/collectivecraft/WebSite/lib/Zend/Db/Adapter/Abstract.php(459): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 /home1/tqbasein/public_html/c/collectivecraft/WebSite/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#4 /home1/tqbasein/public_html/c/collectivecraft/WebSite/lib/Varien/Db/Adapter/Pdo/Mysql.php(419): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
#5 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/Resource.php(169): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
#6 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection('pdo_mysql', Object(Mage_Core_Model_Config_Element))
#7 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(320): Mage_Core_Model_Resource->getConnection('core_write')
#8 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(350): Mage_Core_Model_Resource_Db_Abstract->_getConnection('write')
#9 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(335): Mage_Core_Model_Resource_Db_Abstract->_getWriteAdapter()
#10 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/Resource/Cache.php(53): Mage_Core_Model_Resource_Db_Abstract->_getReadAdapter()
#11 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/Cache.php(455): Mage_Core_Model_Resource_Cache->getAllOptions()
#12 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/Cache.php(497): Mage_Core_Model_Cache->_initOptions()
#13 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/App.php(1183): Mage_Core_Model_Cache->canUse('config')
#14 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/Config.php(414): Mage_Core_Model_App->useCache('config')
#15 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/Config.php(294): Mage_Core_Model_Config->_canUseCacheForInit()
#16 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/App.php(413): Mage_Core_Model_Config->loadModulesCache()
#17 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#18 /home1/tqbasein/public_html/c/collectivecraft/WebSite/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#19 /home1/tqbasein/public_html/c/collectivecraft/WebSite/index.php(87): Mage::run('', 'store')
#20 {main}
  • 2
    i think you database credential is wrong, please verify you database credential and delete content of var/* folder and try – Anil Gupta Jul 3 '13 at 10:13
  • Definitely is wrong - "Access denied for user 'tqbasein_collect '@'localhost'" doesn't leave much room for interpretation. – Mike Jul 3 '13 at 14:57
  • DBA 101 configuration question. Belongs over on magento.stackexchange. – Fiasco Labs Jul 4 '13 at 5:02
  • 2
    This question appears to be off-topic because it is too basic to be asked. It's not a question about Magento, but what does a basic MySql connection error (which is self descriptive) mean. Unlikely to help others, and the info on the error is more than widely known in MySql documentation. – davidalger Jul 6 '13 at 4:25
1

incorrect database credentials

please recreate or recheck database credentials

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.