1

I received this error message when trying out my new shop:

PayPal gateway has rejected request. Billing address request is not enabled for merchant (#11601: Request for billing address failed).

2

Try this in System>Configuration>payment methods>Paypal express checkout (configure)>Basic Settings - PayPal Express Checkout>advanced settings>require customer’s billing address. Set this to No Hope it helps

  • YOU ROCK!! Worked like a charm Thanks a bunch – Bill Feb 5 '15 at 2:45
  • Ok Cool kindly give up my answer:) – mrumair.com Feb 5 '15 at 2:50
0

We are using Magento 2.1.7 and recently experienced the same issue.

In short:

The issue is regarding the option SetCustomerBillingAgreement, which initiates a billing agreement and has been deprecated since v54.0 of the API.

I have more details in my answer to the related question #31887.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.