1
Fatal error: Call to a member function getCode() on a non-object in 
/home/fgdadmin/public_html/factory/includes/src/__default.php on line 40425

NO clue what this means. I could get into the admin section and then it would crash out and spit that error again. Upon refresh, I'd get a 503, so I deleted my cache via FTP. At one point I was able to go in and turn on cache for the site along with another thing. Can't get into admin to remember what it was called. Really don't have too many custom modules and haven't done anything new in recent memory that would make this thing crash out.

It all started about 2 or 3 weeks ago when I'd have to delete the mage--2 folder in my cache when the site crashed and it'd be good for the day. Then it was hourly, now, no website. Over the 3 weeks I kept trying to figure out what it was, but to no avail. HELP please.

Site address is factoryglassdirect.com

Let me know what you need from me and I'll get it to you asap. I'm on here 24/7

2

This is Compile issue at magento.You need to disable Compilation from.

Disable Magento compilation:

$ php -f shell/compiler.php -- disable

Compiler include path disabled

There are two ways in which this can be done:

  1. From Magento admin

Navigate to System > Tools > Compilation page and click on Disable button Navigate to System > Cache Management screen and use Flush Cache button.

  1. Usinf SFTP, by editing at includes/config.php file

To disable compilation in Magento, edit includes/config.php. Uncommitted the first line and comment out the second:

define('COMPILER_INCLUDE_PATH', dirname(FILE).DIRECTORY_SEPARATOR.'src'); define('COMPILER_COLLECT_PATH', dirname(FILE).DIRECTORY_SEPARATOR.'stat');

  1. Using SSH shell program
php -f shell/compiler.php -- disable

php -f shell/compiler.php -- clear

see at

1

This seems problem with compilation. Edit the includes/config.php, change :

define(‘COMPILER_INCLUDE_PATH’, dirname(__FILE__).DIRECTORY_SEPARATOR.’src’);

to

#define(‘COMPILER_INCLUDE_PATH’, dirname(__FILE__).DIRECTORY_SEPARATOR.’src’);

Refresh magento cache, and, that is it!

0

You're not going to be able to identify the cause of the issue until you turn Compilation off. At the moment, Compilation is enabled, which is why you have one gigantic file called __default.php under the includes directory.

Navigate to System > Tools > Compilation page and click on Disable button.

Now, refresh all your caches, and you should either:

  1. Have no error at all
  2. Have a much better understanding of what your error is, because it will give you file and line notation of it.
0

Most probably it is because of compiler's issue.

Disable Magento compilation from command line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.