0

In Magento by default the review page displays the Cart TOTAL EXCL TAX and Cart TOTAL INCL TAX.

Due to the way I've configured Magento (everything including tax), the EXCL TAX and INCL TAX values are identical (which could be confusing for customers).

Does anyone know of a way to remove the EXCL TAX line from the cart review page? (I can't seem to find a configuration option for it anywhere).

3

Found how to do this (programatically)....

Under {magento_base}/app/design/frontend/base/default/template/tax/checkout/

Edit file grandtotal.phtml
(I suggest you make a backup of the file just in case).

Find the line:

<?php if ($this->includeTax() && $this->getTotalExclTax()>=0):?>

Delete the subsequent lines:

<tr>
    <td style="<?php echo $this->getStyle() ?>" class="a-right" colspan="<?php echo $this->getColspan(); ?>">
        <strong><?php echo $this->helper('tax')->__('Grand Total Excl. Tax')?></strong>
    </td>
    <td style="<?php echo $this->getStyle() ?>" class="a-right">
        <strong><?php echo $this->helper('checkout')->formatPrice($this->getTotalExclTax()) ?></strong>
    </td>
</tr>

This change means it will now only show the tax inclusive line in the cart review.

Hope this helps someone else!

  • 1
    Please don't change base/default make this changes in your custom theme – liyakat May 8 '15 at 10:34
0

Please check if changing the below store configuration solve this. So we can avoid a code change.

enter image description here

Which renders the totals as below

enter image description here

./vendor/magento/module-tax/view/frontend/templates/checkout/grandtotal.phtml In this file, the totals INCL and EXCL both loaded only when this condition is satisfied.

<?php if ($block->includeTax() && $block->getTotalExclTax() >= 0):?>

And the includeTax() method check the above-described store configuration value. Switch this "Include Tax in Order Total" to NO in both

Store > Configuration > Tax > Shopping Cart Display Settings = NO

Store > Configuration > Tax > Orders, Invoices, Credit Memos Display Settings = NO

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.