5

I want to copy a Magento site with Redis cache to another server without Redis. Is this possible with just the steps as described here?

Probably that's not enough because it is looking for Redis which is not there.

Edit
I followed the instruction of seanbreeden, but that gives me an error: Connection to Redis failed after 2 failures.

Below my local.xml file

<config>
    <global>
        <install>
            <date><![CDATA[Tue, 11 Mar 2014 20:31:26 +0000]]></date>
        </install>
        <crypt>
            <key><![CDATA[xxxxxxxxx]]></key>
        </crypt>
        <disable_local_modules>false</disable_local_modules>
        <resources>
            <db>
                <table_prefix><![CDATA[]]></table_prefix>
            </db>
            <default_setup>
                <connection>
                    <host><![CDATA[localhost]]></host>
                    <username><![CDATA[magento]]></username>
                    <password><![CDATA[xxxxx]]></password>
                    <dbname><![CDATA[db_magento]]></dbname>
                    <initStatements><![CDATA[SET NAMES utf8]]></initStatements>
                    <model><![CDATA[mysql4]]></model>
                    <type><![CDATA[pdo_mysql]]></type>
                    <pdoType><![CDATA[]]></pdoType>
                    <active>1</active>
                </connection>
            </default_setup>
        </resources>
        <session_save><![CDATA[files]]></session_save>  
    </global>
    <admin>
        <routers>
            <adminhtml>
                <args>
                    <frontName><![CDATA[admin]]></frontName>
                </args>
            </adminhtml>
        </routers>
    </admin>
</config>

And app/etc/modules/Cm_RedisSession.xml

<config>
  <modules>
    <Cm_RedisSession>
      <active>false</active>
      <codePool>community</codePool>
    </Cm_RedisSession>
  </modules>
</config>

3 Answers 3

12

Yes, with the additional step of removing the lines in app/etc/local.xml that involve Redis and removing any Redis extensions that you have installed. Most likely, the only one you'd have will be Cm_RedisSession. You can disable that extension by editing the app/etc/modules/Cm_RedisSession.xml file and changing the enabled node from true to false.

Your app/etc/local.xml should look similar to this on your new site:

<config>
<global>
<install>
  <date><![CDATA[Thu, 1 Jan 2015 19:00:00 +0000]]></date>
</install>
<crypt>
  <key><![CDATA[XXXXXXXXXXXXXXXXXXXXXXXXXXXX]]></key>
</crypt>
<disable_local_modules>false</disable_local_modules>
<resources>
  <db>
    <table_prefix><![CDATA[]]></table_prefix>
  </db>
  <default_setup>
    <connection>
      <host><![CDATA[DATABASE_HOST]]></host>
      <username><![CDATA[USERNAME]]></username>
      <password><![CDATA[PASSWORD]]></password>
      <dbname><![CDATA[DATABASE_NAME]]></dbname>
      <initStatements><![CDATA[SET NAMES utf8]]></initStatements>
      <model><![CDATA[mysql4]]></model>
      <type><![CDATA[pdo_mysql]]></type>
      <pdoType><![CDATA[]]></pdoType>
      <active>1</active>
    </connection>
  </default_setup>
</resources>
<session_save><![CDATA[files]]></session_save>
</global>
<admin>
<routers>
  <adminhtml>
    <args>
      <frontName><![CDATA[admin]]></frontName>
    </args>
  </adminhtml>
  </routers>
</admin>
</config>
8
  • Oké, I will try this!
    – Timo002
    Feb 2, 2015 at 21:23
  • 2
    Hmm, not working! It tells me Connection to Redis failed after 2 failures. My Cm_RedisSession.xml file contains <config> <modules> <Cm_RedisSession> <active>false</active> <codePool>community</codePool> </Cm_RedisSession> </modules> </config>
    – Timo002
    Feb 2, 2015 at 22:12
  • Do you have session save set to "files"? <session_save><![CDATA[files]]></session_save> Feb 2, 2015 at 22:23
  • 2
    Are there any other xml files in app/etc? If any of them have redis entries then move them out of that folder. Be sure to flush your cache as well. Feb 3, 2015 at 1:40
  • 2
    YES, there was an fpc.xml as wel that caused this. Renamed the file, flushed all the cache and now it is working! Thanks!
    – Timo002
    Feb 3, 2015 at 8:34
1

I confirm that making sure there are no other .xml file in app/etc that contain redis configuration such as old local.old.xml or fpc.old.xml. The system will still use these files for configuration and detect redis configuration in them.

1
  • I found this cache file in lib\Cm\Cache\Backend. Aug 8, 2018 at 9:31
0

When installing on a server with SeLinux check SeLinux is not blocking the connection to the Redis server. On my new server SeLinux was enforcing. When SeLinux was disabled, everything worked fine.

You can check /var/log/audit/audit.log for SeLinux error messages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.