0

Got these warnings while accessing the localhost/magento ‘homepage’:

Warning: include_once(C:\xampp\htdocs\magento/errors/503.php): failed to open stream: No such file or directory in C:\xampp\htdocs\magento\index.php on line 65

Warning: include_once(): Failed opening ‘C:\xampp\htdocs\magento/errors/503.php’ for     inclusion (include_path=’.;C:\xampp\php\PEAR’) in C:\xampp\htdocs\magento\index.php on line 65 

But, then On commenting/hiding these lines in index.phtml, the homepage was successfully accessed:

/* 
if (file_exists($maintenanceFile)) { 
include_once dirname(__FILE__) . ‘/errors/503.php’; 
exit; 
} 
*/ 

Now the problem is that, though changing the ‘cart ‘s’ position or adding the products categories, it didnt showed up in frontend… Dont' know what might have got 'misconfigured....' Please help me to figure out these simple messed-up hussle…

  • Code hack instead of removing maintenance.flag file from Magento root folder. This is a configuration issue with a Windows based XAMPP installation and belongs over in magento.stackexchange as it is not a programming question. – Fiasco Labs Jul 2 '13 at 19:49
  • after successful installation, why do i need to hide those blocks instead of opening the homepage without errors.... and if its installation problem, then is this why, i might be facing other problems in display... Im not gettting any connection with all this!! :( – sumit kumar Jul 3 '13 at 9:00
1

You have a few potential issues here:

  • Delete the file from your Magento root folder called maintenance.flag. This is what's causing the redirect in the first place.

  • Your errors directory may be missing or the file 503.php in side it, or both. Replace them.

  • Your PHP install is trying to locate the 503 error route but it is loaded from your Xampp's Apache installation with the wrong directory separator. This shouldn't be a problem on Windows, as both slashes will work, even when used inline:

-

C:\Documents and Settings>cd C:\Users

C:\Users>cd C:/Users\pjackson

C:\Users\pjackson>

If you're really concerned about mixed slashes, you can modify index.php accordingly:

if (file_exists($maintenanceFile)) { 
include_once dirname(__FILE__) . DS . 'errors' . DS . '503.php';
exit; 
} 

But, I highly advise you don't mess with your index.php.

0

Look at the path it's trying to look at, you have half operating system, half web server.

C:\xampp\htdocs\magento - Operating system part.

/errors/503.php - server part.

The operating system part should be something like "/xampp/htdocs/magento/" or "http://www.example.com/magento/"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy