2

after update the store from 1.8.1 to 1.9.1.0, when i add to cart a configurable product and i logged in, the system return the page 503.

The same operation, but if not logged in work correctly. The system.log and exception.log don't report an error related to this issue.

Our hosting provider, believe this error is caused by a bug in PHP/Zend framework. We have tried with PHP 5.5 as well with same results so at this point there is not much more we can do.

A bug report has been submitted: https://bugs.php.net/bug.php?id=68958

all suggestions are much appreciated.

1
  • Have you checked var/report/ folder? Jan 31, 2015 at 0:41

3 Answers 3

4

I had a similar issue with configurable products (not 503 error but infinite loop) after upgrading from 1.6.2 to 1.9.1 As @ladle3000 suggests it was also related to shopping cart rules that had a condition related to a category. If I deactivated or deleted the rules, no more issues.

Check out the changes I did here: "Please specify the product's option(s)." after magento upgrade 1.6.2 to 1.9.1 It fixed my issue

There is also more about this Magento 1.9.1 bug here: Magento debug trace

1
  • The answer in the "Magento debug trace" question fixed it for me in 1.9 Sep 28, 2016 at 9:05
2

I know the answer. For our store the situation arose from an old shopping cart rule. It seems there is some issue with old rules that use certain conditions in which an infinite loop is caused. Such as name contains, etc.

It sounds like this is your issue too, because probably you have a rule that only applies to certain groups.

Hope it helps, I got a lot of stress over this issue.

2
  • To quick test get in your database, and quick switch all your rules to inactive. If it fixes the issue, turn them back on one by one to isolate.
    – ladle3000
    Jan 31, 2015 at 1:48
  • Actually, if you confirm this. Check if one of your rules has 'is one of' or 'is not one of' condition. There seems to also be in issue in catalog rules with this condition not working, although in catalog rules it just doesn't apply the discount (not the infinite loop like shopping cart rules).
    – ladle3000
    Jan 31, 2015 at 1:53
1

Experienced the same issue. 503 error when adding configurable products to cart after upgrade from 1.9.0.1 to 1.9.1.0. Disabling an old shopping cart price rule fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.