1

I have a problem where magento keeps deducting the tax from the order total. Can't figure out why it's doing that. As you can see in below picture. The order total should be €5,20. But the €0,90 is being deducted instead.

enter image description here

Here's my tax rule, vat is set to 21%:

enter image description here

Here are my settings in the backend:

enter image description here

Does anyone know where I should look to fix this? Thanks

As for clarification:

enter image description here

As you can see. The total should be €7,20. But the VAT/TAX of €1.25 is deducted instead. Totalling: €5,95.

1

please check if the flag "Include Tax in Grand Total" is set to Yes,

This settings in sistem->configuration->Tax->Shopping Cart Display Settings"

In mine default installation is set to "No" enter image description here

Giuseppe

4
  • Hi, thanks for your reply. Sorry to say that it doesn't work.
    – Feggel
    Jan 30 '15 at 13:47
  • That will only 'show' extra tax information. It doesn't solve the problem, that magento is deducting the vat instead off adding it.
    – Feggel
    Jan 30 '15 at 15:54
  • Please try to show both price for the total including and ecxluding tax. This will help you to verify if it is a calculation error or just a visualization one.
    – Giuseppe
    Jan 31 '15 at 15:08
  • I've enabled all displaying options from the backend. Added the screenshot to my question. But as you can see. The VAT is still being deducted. It's plain weird.
    – Feggel
    Feb 5 '15 at 8:13
0

Finally I've figured out what was wrong.

We were using ET Payment Extra Charge extension. I thought disabling it from the backend would show me if this would be the culprit.

But I had to completely remove it.

Now the tax calculation is correct agian. So check your extensions!

Everybody thank you for your help!

0

Debugging Magento 101: TURN OFF ALL YOUR CRAPPY MODULES !! And flush your cache by removing all files in var/cache or with Redis command "flushall". Or go to the beckend and do it there and wait a while..... :-(

You have to do this in app/etc/modules/xxxxxx.XML If you disable it in the backend. Your only disable output of blocks.

Just look at: Mage_Core_Block_Abstract..... toHtml() !

-1

Check if Mage_Tax is enabled (System->Configuration->Advanced)

2
  • 1
    This doesn't answer the question, you should place a comment to ask if they have done this Jan 30 '15 at 18:43
  • 1
    Yes it is enabled. Otherwise tax wouldn´t function at all.
    – Feggel
    Feb 5 '15 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.