I am running an old version of Magento - 1.3.1

Now - I would like to install the newest version (1.9.1) for a new store (different domain) on the same server. I have done that and it works. However, when I install a new theme - it gives me the following Error - CONNECT ERROR: Package community/AccessShop_Theme 1.0.0: requires PHP version >= 5.4.0 and <= 5.6.0 current is: 5.3.28

What would happen to the old Magento store (version 1.3.1) if I upgrade the pHp on the server to something like 5.6.0? Would it work or would it kill it?

Any other suggestions?

  • 1
    go to 5.4 upgrade, and check if your have applied 5.3 patch before. – user2857 Jan 29 '15 at 18:48

Magento currently does not officially support PHP 5.6., the latest version has only started officially support PHP 5.5. - http://magento.com/blog/magento-news/magento-community-edition-191-now-available-download

I would think that if you updated your version of PHP to 5.6, it would break the older site and also possibly your new site would not work on PHP 5.6. Even if you were to update to PHP 5.5 the older site would not work.

You could update and then try and change the PHP version of the older site using the .htaccess file - https://stackoverflow.com/questions/12105632/change-php-version-on-server-using-either-htaccess-or-php-ini but this may not work.

You really don't want to be running 1.3 and 1.9 on old versions of PHP, you should keep the latest versions with the latest versions and old with old, otherwise you run in to incompatibilities. Most of the sites on 1.9 use 5.4 or a variant thereof. About your SEO question, you want to perform a migration from 1.3 to 1.9 which is a clean install and moving products and customers across. This would be at the same time as a server upgrade, an upgrade is a dual upgrade process from 1.3 and it's not a good idea.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.