0

I am new to Magento and Magmi but I succeeded in doing an ok Job with Mangento and Magmi on my local virtual server (Mamp). Now I want to go live but I can’t seem to use Magmi on my production server with Bluehost. When I import my product files, it just said NO FILE. I think it is a problem with permissions but I am not really sure. I tried to give 777 permissions to most of the files (Conf, state, …) but doesn’t seem to work. So I decided to go through CLI as I read it doesn’t need permission settings. But when I tried to import with the command line

php magmi.cli.php -mode=create -CSV:filename=/home3/tunique1/public_html/magmi/var/import/simple.csv

The follow error Log appears in CLI folder :

PHP Warning:  require_once(./inc/magmi_defs.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /home3/tunique1/public_html/magmi/engines/magmi_productimportengine.php on line 11

PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required './inc/magmi_defs.php' (include_path='.:/usr/lib64/php:/usr/share/pear:/home3/tunique1/public_html/magmi/inc:/home3/tunique1/public_html/magmi/integration/inc:/home3/tunique1/public_html/magmi/engines') in /home3/tunique1/public_html/magmi/engines/magmi_productimportengine.php on line 11

Could you help me with this problem ?

  • It is basically saying a file is missing. Make sure the magmi/inc/magmi_defs.php is present. – Chris Carter Jan 27 '15 at 13:32
  • Thank you for your reply ! The file is there so I don't really understand why it cannot find it. – Jaak Jan 28 '15 at 2:32
  • Thanks for the tips. After you said it was missing but in fact it did not. I looked around PHP.ini and realised my previous web designer changed the PHP version of my server... Magmi and the UI is working now. – Jaak Jan 28 '15 at 3:35
-1

For the NO FILE problem on Magmi UI. I just realised it was the wrong PHP version on my server... i changed from 5.2 to 5.4 and it was working again.

Thank you,

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.