I am building my first Magento store, but I found out that I can't add images to products. It is testing site, so I am learning how things are functioning in Magento.

I tried almost everything - reinstalled flash, shockwave, browsers, updated prototype... No luck.I tried in 5 browsers.

Is there anything elese I can do to try to fix it?

Here is a print screen


13 Answers 13


I found this issue when I had extended and created my own theme for the admin area.

These buttons use FLASH.

So if your browser does not support flash - then they will not appear.

Ensure that the app/design/adminhtml/default/default/template/media folder exists and that there are 2 files within it.

  • editor.phtml
  • uploader.phtml

Ensure that the skin/adminhtml/default/default/media folder exists and that there are 3 files within it.

  • flex.swf
  • uploader.swf
  • uploaderSingle.swf

If you have created your own theme (ie Theme: "mytheme" and Package "mypackage") then ensure the above applies for:

  • app/design/adminhtml/mytheme/mypackage/template/media
  • skin/adminhtml/mytheme/mypackage/media

I hope this helps.

  • 4
    Thanks a lot. This happens, if you are using git and you are writing the line media/ instead of /media to the .gitignore-file. Commented Mar 22, 2016 at 10:00
  • 1
    Please note that this answer is outdated. You should NOT have the .swf files anymore in your media folder for security reasons.
    – Marcel
    Commented May 4, 2017 at 10:06
  • 1
    Update - this fix should only work for pre 2.0 versions. Commented Jun 21, 2017 at 14:12

These buttons are coming from flash.So check your media folder on following location


if there is no media folder then copy from fresh magento

This will solve your problem :) if not Try solution from below links https://stackoverflow.com/questions/15022532/image-upload-buttons-are-missing-in-magento-in-back-end



Funny thing, i had the same kind of problem in the project i currently work, but all files were in place (Talking about Magento Version

First i thought the issue are the missing '' here

var maxUploadFileSizeInBytes = <?php echo $this->getDataMaxSizeInBytes() ?>;

found in several places, for example in

  • "app/design/adminhtml/default/default/template/media/uploader.phtml"
  • "app/design/adminhtml/default/default/template/cms/browser/content/uploader.phtml"

But that lead to a new error, so the final solution was to change the php.ini like that:

upload_max_filesize = 100 M 


upload_max_filesize = 100M

I tried all the solution,but still i was not able to resolve this problem.

I got it resolved by downloading the Adobe flash for the browser (Firefox) that worked for me.

  • It is coming for product images but not for CMS page editor. Commented Jul 25, 2019 at 7:00

Edit your /app/design/adminhtml/default/default/template/media/uploader.phtml

var maxUploadFileSizeInBytes = '<?php echo $this->getDataMaxSizeInBytes() ?>';
var maxUploadFileSize = '<?php echo $this->getDataMaxSize() ?>';

replace with

var maxUploadFileSizeInBytes = '128M';
var maxUploadFileSize = '128M';
  • How would this help with displaying the buttons? It looks more like uploader files missing or Flash not working properly Commented Apr 11, 2015 at 10:28
  • The problem here was not getting the size from "getDataMaxSizeInBytes()". So when i manually given the size the buttons were displayed automatically.
    – Dinoop V P
    Commented Apr 16, 2015 at 13:48

There is three thinks: - HHVM (misconfiguration)





and replace :

public function getPostMaxSize()
    return ini_get('post_max_size');

public function getUploadMaxSize()
    return ini_get('upload_max_filesize');


public function getPostMaxSize()
    $post_max_size = ini_get('post_max_size');
    return $post_max_size ? $post_max_size : ini_get('hhvm.server.max_post_size');

public function getUploadMaxSize()
    $upload_max_filesize = ini_get('upload_max_filesize');
    return $upload_max_filesize ? $upload_max_filesize : ini_get('hhvm.server.upload.upload_max_file_size');

This is finally solution to fix problem entirely.


I had the same problem and I fixed it like this: in chrome enter the following url


You will see a popup, scroll down until you see flash, select allow sites to run flash.



To fix the product image upload button not loaded in Magento CE, I had to add ' character in maxUploadFileSizeInBytes value.


var maxUploadFileSizeInBytes = <?php echo $this->getDataMaxSizeInBytes() ?>;


var maxUploadFileSizeInBytes = '<?php echo $this->getDataMaxSizeInBytes() ?>';



If you are using Git, make sure your .gitignore file doesn't inadvertently exclude Shockwave Flash files.

My .gitignore had the line:


Which was supposed to exclude *.swp, *.swo, etc but I hadn't thought about *.swf at the time.

So I changed it to:


I also had this issue, and it was because I wanted to control my unsercure & secure base urls for front & admin from within my local.xml

So if your unsecure & secure base urls is controlled with your local.xml you might run into this issue. I have not had time to work on a fix for this yet

Hope this helps!


I had this same problem on Magento with HHVM. I discovered that the problem was from HHVM. Switching to PHP5-FPM solved the problem for me.

  • can you please explain me how can i switch to PHP5-FPM? Commented May 17, 2017 at 12:12
  • There is an article for installation php5.6-fpm here: tecadmin.net/install-php5-on-ubuntu. You would need to replace the HHVM address or socket with that of php5.6 after the installation.
    – Ndianabasi
    Commented May 18, 2017 at 14:43

I had the same issue. Following is what fixed the issue for me:

In app/design/adminhtml/default/default/template/media/uploader.phtml

Replaced getUploaderUrl('media/uploader.swf') ?> with the exact path of the uploader.swf https:///skin/adminhtml/default/default/media/uploader.swf


Please update the browser and install latest flash player...

Not the answer you're looking for? Browse other questions tagged or ask your own question.